2

I'm running Ubuntu Touch 15.04 on Nexus 4 and GPS does not work.

Of course I enabled 'Location Detection' and 'GPS' in the top menu. Furthermore I have enabled 'Celluar Data' in the Settings menu and gave permissions to the corresponding apps.

Unav, GoogleMaps and Sensorstatus, they all are not able to locate me.

I tried it with the stable channel (15.04 r5) and the RC channel (15.04 23 (I.e. OTA7))

Anyone any Idea to use GPS successfully?


Here are some screenshots. I wonder, cause there are less possibilities than in costales links.

Settings[1]

Settings[2]

I even tried it near the window over hours with WIFI powered of.

I flashed now the rc-proposed/BQchannel. My settings menu looks now different, but GPS is still not working.

Settings[3]

Settings[4]

Finally I found this Bug-Report, maybe it is an already known bug.

3

You can use GPS in two ways on Nexus 4.

  1. With Normal GPS.
  2. With A-GPS (Assisted GPS with anonymized Wi-Fi and cellular network info; it can be named as Nokia HERE service as well).

1. Usage with GPS

Go to location settings and select "Using GPS only".

enter image description here

The problem this is option, that it can take a long time to get position the first time. So put your phone near the window, open uNav app (Ubuntu navigation application), tap on a button to find your position, and leave it for an hour with uNav app open untill it finds your position. If it does not find the position, review the GPS settings (check at the bottom of battery settings too), try enable/disable. If everything is OK, try reboot a device. Then go to uNav application and try again untill it finds your position.

Then it finds your position, then navigation works very well. But if you experience any issues using navigation (navigation stops, is choppy or does not the direction), close other apps that might be using navigation as well at the same time (if it does not help, remove GPS permissions from other apps) (this is a known bug, bug report here)

2. Usage with A-GPS

Benefit of this way is that it immediately finds your position and you don't have to wait.

Main Ubuntu channel does not use third-party services, so this option is only available if you flash bq-aquaris.en channel to your device. This channel is adapted for use of several devices, including mako (Nexus 4).

Instruction how to change channel:

  1. Install developer tools on your computer (more info here)
  2. Enable developer mode on your phone (Settings > About > Developer mode > Enable)
  3. Connect the phone to the computer.
  4. In terminal write "adb reboot recovery"
  5. Phone restarts automatically and enters screen with android picture.
  6. In terminal write "ubuntu-device-flash touch --channel=ubuntu-touch/stable/bq-aquaris.en"
  7. Wait untill ubuntu flash the image and boots up. Finish.

Now you will find A-GPS setting on your device, select it.

enter image description here

If it does not find your position immediately, restart your phone and try again.

If after finding the position navigation does not work well, then again, close other apps that might be using navigation as well at the same time for it to work well (see https://bugs.launchpad.net/ubuntu/+source/location-service/+bug/1468020)

Other notes:

  1. A-GPS works independent of radio version, it can be old or new, does not matter.
  2. Compass is not yet implement on Ubuntu Touch, but it calculates your correct direction then you are driving, so its fine.
  • re-post, could not understand why previously this answer was deleted since it finally answers this question and was accepted as the best answer. I think it was some kind of mistake. – Mindaugas Apr 21 '16 at 17:29
  • For me works now very good. I don't need to switch the app. Compass seems to be not implemented on Nexus4. Thats why the direction works just if you are moving. – eDeviser Apr 22 '16 at 5:23
  • Glad it works well for you. For me the issue persists. Yesterday I posted a bug report, I'll inform about results. True, it seems that compass is not implemented on any of the phones at the moment. – Mindaugas Apr 22 '16 at 8:45
  • Would you please share the link to the bug? – eDeviser Apr 22 '16 at 12:39
  • It worked with simple GPS! :)) Updated the post above how I did it and other most up-to-date information. You can find bug report here bugs.launchpad.net/unav/+bug/1573140 – Mindaugas Apr 22 '16 at 19:09
1

Just FINALLY got something to work after months of it being broken. I flashed the latest radio available from Google. Go here, link, scroll down to the Nexus 4 section, the bottom one is the latest. Download it, extract it, cd to the directory extract it, then do:

adb reboot bootloader

fastboot flash radio radio-mako-m9615a-cefwmazm-2.0.1701.07.img

Then I flashed the rc bq-aquaris.en channel:

ubuntu-device-flash touch --channel=ubuntu-touch/rc/ubuntu/bq-aquaris.en

Now HERE maps and uNav work as expected, as does google maps and the weather app.

  • What is the latest radio? I do not understand? Is it something like a baselayer of software, like a BIOS, which is running in background of Ubuntu Touch? – eDeviser Jan 19 '16 at 23:31
  • 1
    Go here, developers.google.com/android/nexus/images, scroll down to the Nexus 4 section, the bottom one is the latest. Download it, extract it, cd to the directory extracted then do "adb reboot bootloader" and then run the fastboot command above. It is a bit like BIOS, it's the radio firmware which the Ubuntu OS talks to when using WiFi, GPS, Bluetooth ecc. – Tom Rhodes Jan 20 '16 at 13:49
  • Do I need to reflash my device after flashing the radio firmware? I. E. Will my personal data be lost? – eDeviser Jan 20 '16 at 18:58
  • No, just flash the radio when in the bootloader using fastboot and then restart it. Once restarted if you aren't already on the rc bq-aquaris channel then do the second part of my answer above. do "adb reboot recovery" in the terminal and then "ubuntu-device-flash touch --channel=ubuntu-touch/rc/ubuntu/bq-aquaris.en". Once you then restart the phone you shoudl have GPS fully working on your nexus 4!. Just don't run the flash-all script in the same folder as the radio img file. That is the only way you will lose data. – Tom Rhodes Jan 22 '16 at 15:03
1

I found that switching to the bq-aquaris.en stable channel solved the problem. I was on ubuntu-touch/stable/ubuntu with latest Nexus 4 radio (radio-mako-m9615a-cefwmazm-2.0.1701.07.img) and GPS was not working.

With the phone plugged into my computer, run this:

ubuntu-device-flash touch --channel=ubuntu-touch/stable/bq-aquaris.en

and the phone switched to the bq-aquaris.en channel with all my data and settings preserved, plus working GPS!

  • Hmmm, this all seems to be very buggy, I tried everything: Flashing new Radio, using aquaris stable and rc channel... Well Aquaris works better than the normal ubuntu channel, but the signal quality is always too bad. I even found now out, that the the speaker can't be unmuted, sometimes. If I restart my phone a couple times, it works again.. ...I remember once in the past GPS was working perfectly for a feq days... ...I think there are huge problems in hardwareDriverLayers... – eDeviser Feb 20 '16 at 9:44
  • I'm seeing more bugs on the bq-aquaris channel (trouble switching networks etc) than on the Ubuntu channel, but gps has been consistently good for me on it. For me, having gps outweighs having to fiddle with a few other things. Haven't run into the speaker issue, except that on any channel the sound settings aren't always preserved across apps. – mrm Feb 20 '16 at 11:21
0

An uNav developer here |o/ Maybe I could help you a little.

Check the phone configuration is like these screenshots:

A hug!

  • Thanks for your hugs.:) I added screenshots in my post above. – eDeviser Nov 1 '15 at 1:53
  • This seems to be the bug report bugs.launchpad.net/oxide/+bug/1462664 but it was supposed to be fixed with the OTA8, I am using the OTA8.5 and I am facing the same problem on the Nexus 4 – Freefri Dec 29 '15 at 15:29
  • Try the settings into battery too – Costales Apr 21 '16 at 20:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.