I upgraded from 15.04 to 15.10 on a Lenovo Carbon X1 (3rd gen), and now when the laptop boots it stops with the message:

[drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!

I tried different kernels (4.x upstart, recovery, 3.19) and they all throw the same error.

Any ideas?

  • Is your laptop connected to an external monitor? I found this bug that seems relevant.
    – Jos
    Oct 29 '15 at 9:13
  • No, its not connected to anything. I've seen the refs to external monitors mentioned. Its a new laptop, worked great at 15.04. Dead with 15.10.
    – Harel
    Oct 29 '15 at 9:29
  • You could try booting with the nomodeset boot parameter.
    – Jos
    Oct 29 '15 at 9:43
  • I will try yes though I don't get a black screen or anything like that - just a the boot process logs which then gets stuck with that error. I am thinking to reinstall 14.04 (or maybe 15.04) which were fine and stable.
    – Harel
    Oct 30 '15 at 10:31

Not sure if this would apply to everyone, but it worked for me: I downloaded 15.10 to a USB stick and run the installation again from scratch. It wrote over the existing install, kept my home directory and even some of the installed applications. For example, once I reinstalled Java from Oracle, the previously installed PyCharm started working again. Even steam still had my account logged in once I reinstalled it.

  • And then it didn't work.... Worked for a while, then reverted back to the same error message on boot.
    – Harel
    Nov 23 '15 at 20:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.