2

I'm currently running Ubuntu 14.04 LTS with Unity on a relatively new ASUS Zenbook UX303-LB. I have been trying unsuccessfully to get gestures working for a good several weeks now, on and off, as I currently have NO gesture support. All I can do is tap 1 finger to click, drag 1 finger around to move the cursor, and use the physical buttons. I don't even have any of the gestures listed here that should supposedly work on any touchpad right out of the box (tested multiple times and confirmed).

I tried following the steps in the answers to this similar question, to no avail.

I also tried doing something similar to the first answer in this other (also similar) question - didn't help, but it did give me a message on boot telling me I don't have Synaptics drivers installed, which is what led me to discover I have a FocalTech touchpad, not Synaptics. I did NOT rebuild Unity from source, because that only (potentially) changes 3-4 touch gesture behavior, which I don't really care about.

I then proceeded to try and follow some of the steps from the Ubuntu wiki page I linked above, but they seem to be written only for Synaptics touchpads (and are 3+ years old).

In any case, this is what I get out of xinput list-props [my touchpad]:

Device 'PS/2 FocalTech FocalTech Touchpad in mouse emulation mode':
    Device Enabled (139):   1
    Coordinate Transformation Matrix (141): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    Device Accel Profile (264): 0
    Device Accel Constant Deceleration (265):   1.000000
    Device Accel Adaptive Deceleration (266):   1.000000
    Device Accel Velocity Scaling (267):    10.000000
    Device Product ID (256):    2, 1
    Device Node (257):  "/dev/input/event4"
    Evdev Axis Inversion (268): 0, 0
    Evdev Axes Swap (270):  0
    Axis Labels (271):  "Rel X" (149), "Rel Y" (150)
    Button Labels (272):    "Button Left" (142), "Button Unknown" (259), "Button Right" (144), "Button Wheel Up" (145), "Button Wheel Down" (146)
    Evdev Scrolling Distance (273): 0, 0, 0
    Evdev Middle Button Emulation (274):    0
    Evdev Middle Button Timeout (275):  50
    Evdev Third Button Emulation (276): 0
    Evdev Third Button Emulation Timeout (277): 1000
    Evdev Third Button Emulation Button (278):  3
    Evdev Third Button Emulation Threshold (279):   20
    Evdev Wheel Emulation (280):    0
    Evdev Wheel Emulation Axes (281):   0, 0, 4, 5
    Evdev Wheel Emulation Inertia (282):    10
    Evdev Wheel Emulation Timeout (283):    200
    Evdev Wheel Emulation Button (284): 4
    Evdev Drag Lock Buttons (285):  0

This thing works like an absolute charm in Windows 10, so I know there isn't anything wrong with it. Anyone know what to do?

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.