2

I updated from 15.04 to 15.10, and then got a blank screen when booting up (the blank screen came after grub). After figuring out how to get to a console, I uninstalled and reinstalled different graphics drivers until it would boot correctly (by uninstalling all of them it worked). However, it detected my monitor as a built-in display. I tried to work around this be forcing my correct resolution 1600x900. By using cvt and xrandr I was able to create a new mode 1600x900_60.00. But I couldn't use it because the highest resolution was 1400x1050.

TL;DR Graphics drivers don't work, and I can't change resolution above 1400x1050.

Does anybody know how to restore my proprietary graphics drivers (mainly fglrx)?


Extra Details:

Graphics card - AMD Radeon HD 6670

Ubuntu version - 15.10

Monitor - View Sonic VA2033-LED

Monitor resolution - 1600x900

Active graphics driver - X.Org X server (default open-source driver)

  • 1
    Similar thing happens to me on 15.10. The external monitor for my Dell XPS 12 is detected as unknown and only offers low resolution settings. Back to 15.04 for me. – Mike McKay Oct 29 '15 at 8:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.