32

Ubuntu can't be installed on my system because of what the title says. This is because support Intel HD Graphics 530 was only just added in Linux kernel 4.3 and all versions of Ubuntu only have kernel versions up to 4.2 as of 15.10. My computer's processor is the new Intel Skylake 6600K if you need to know, everything else is generic. It has a UEFI BIOS motherboard. Help?

  • 3
    Compile your own kernel? kernel.org – A.B. Oct 28 '15 at 20:04
  • 2
    Then you have a problem now. Sorry :\ – A.B. Oct 28 '15 at 20:07
  • @A.B. There is no need to compile a kernel. It is possible to get a deb. But the problem is how to install OS with that kernel. – Pilot6 Oct 28 '15 at 20:12
  • 2
    Can you boot in low-graphic mode? A solution would be to get through the installer and install an (unstable) mainline kernel (last version is 4.3rc7, so it shouldn't be that bad). – kos Oct 28 '15 at 20:15
  • 2
    Some time very soon kernel 4.3. will land in the Xenial daily live CD - this will be an unstable distribution then, but at least better than nothing. – Takkat Oct 28 '15 at 20:19
22

Boot with nomodeset boot parameter as it is described in this answer.

You will be able to install Ubuntu. After you do it, the system will probably won't boot again.

You will have to get to grub menu by pressing Shift or ESC button and enter nomodeset again.

Then install 4.3 kernel. It can be done this way. Run in terminal:

mkdir ~/linux-4.3
cd ~/linux-4.3
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.3-wily/linux-headers-4.3.0-040300-generic_4.3.0-040300.201511020949_amd64.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.3-wily/linux-headers-4.3.0-040300_4.3.0-040300.201511020949_all.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.3-wily/linux-image-4.3.0-040300-generic_4.3.0-040300.201511020949_amd64.deb
sudo dpkg -i *.deb

and reboot. I hope the system will boot without the nomodeset parameter.

Notice: The kernel will not get updates. You will need to install them manually from Mainline kernel PPA.

  • 3
    If Intel Video you may need this, until newer versions of drivers come out: Skylake needs this boot parameter: i915.preliminary_hw_support=1 phoronix.com/… – oldfred Oct 28 '15 at 21:56
  • Maybe not with 4.3. We'll see. – Pilot6 Oct 28 '15 at 22:03
  • What happens if I do this while I have already installed propitiatory drivers for my Nvidia graphics card? – Switch Oct 29 '15 at 18:45
  • Please ask a new question, describing your situation. – Pilot6 Oct 29 '15 at 18:47
  • No idea how it works for me, but I installed Ubuntu gnome 15.10 on i7-6700 and it just works. Only thing possibly worth mentioning is that I enabled internet during installation. – dbrank0 Jan 5 '16 at 13:57
2

I've got Ubuntu 15.10 Mate running fine with Metacity installed, as it seems more stable.

I thought Ubuntu had made tweaks to the stock kernel of 4.2 for Skylake read here:

http://www.phoronix.com/scan.php?page=news_item&px=intel-skl-prelim-support

I'm running a sixth generation intel core i5 6500. Had a few slight issues under compbiz and marco (partial screen freeze) but metacity has been stable for days. I've got a core i5 6500 with a Gigabyte B150M D3H motherboard and DDR4 ram (8GB). Just using on board graphics.

The only issue I've had in the last few days whilst using metacity is youtube on Chrome will cause a strange ghosting of the browser if I attempt to move the browser along the screen, so I use firefox for YT and its fine. Its been quite stable thus far.

2

New kernel version 4.8.10 (November 23, 2016)

Steps everyone can take are to ensure Intel microcode is up to date. See the answer here: (Ubuntu 16.04 Skylake overheating)

Instead of kernel 4.2, 4.3 or 4.4.2 in the other answers here you should upgrade to kernel 4.8.10 which has good reviews / improvments:

cd /tmp
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.8.10/linux-headers-4.8.10-040810_4.8.10-040810.201611210531_all.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.8.10/linux-headers-4.8.10-040810-generic_4.8.10-040810.201611210531_amd64.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.8.10/linux-image-4.8.10-040810-generic_4.8.10-040810.201611210531_amd64.deb
sudo dpkg -i *.deb
sudo reboot

After installing the new kernel you can try to roll out grub command line changes for nomodeset, i915.preliminary_hw_support=1, etc. you fudged to make earlier kernels and drivers work.

Please note kernel version 4.9 LTS will be out soon. We all hope Intel fixes the pstate / cstate / thermald issues plaguing many of us in the LTS kernel release.

1

I had the same issue, that I wasn't able to install Ubuntu 15.10 on my new Thinkpad. Therefore I add here my solution to the problem, because it could help someone. I tried different kernel parameters in the boot options and I got it to work when I replaced quiet splash --- with:

i915.preliminary_hw_support=1 nouveau.blacklist=1 edd=on nolapic pcie_aspm=force tpm_tis.interrupts=0 ---

After I was able to boot into my Ubuntu installation I made a update of the kernel to 4.3 and now I only use one kernel parameter nolapic to start it. But to enable the touch and digitizer I need to add i915.preliminary_hw_support=1 .

1

I have written a manual for the black screen boot issues and enabling working wi-fi for Ubuntu 15.10: http://www.ambience.sk/dell-xps13-touch-9350-ubuntu-black-screen-boot-wifi/

If you have the latest Dell XPS13 Touch (9350) with Skylake and Intel Graphics i915 running Ubuntu 15.10 (or any other version such as 15.04 or 16.04), you will need to make some changes to make it boot safely without running into the black screen issues. Also, you will enable wifi this way.

To install Ubuntu (Kubuntu or any other distro or flavor), you will need an UEFI-enabled Linux distro.

To enable wifi you need the latest (4.4+) kernel. To ensure smooth and working booting via GRUB, you will need to enable some modules and update GRUB2 parameters.

Linux UEFI Installation on Dell XPS13 (9350)

  1. Press F2 on booting (while the Dell logo is displayed) and enter the UEFI BIOS.

  2. Go to General -> Advanced Boot Options and set to disable all.

  3. Go to System Configuration -> SATA Operation and change to AHCI.

  4. Go to Secure Boot -> Secure Boot Enable and switch to Disabled.

  5. Go to POST Behavior -> Fastboot and set to Thorough.

  6. Additionally (after the install), you can change General -> Boot Sequence to whatever order you prefer and add GRUB2 – choosing EFI/ubuntu/grubx64.efi.

  7. After the installation of Ubuntu (or any other Linux is done), update it to the latest kernel to make wifi work on Dell XPS13 (9350), e.g. 2015 and 2016 models.

    1. Download the latest stable kernel (e.g. 4.4.2)

      First, you will need to upgrade your kernel to 4.4.2 to support both wifi and Intel i915 graphics:

      wget in4serv.com.br/backup/kernel-4.4.2
      sudo chmod +x kernel-4.4.2
      ./kernel-4.4.2
      
    2. Add modules to initramfs

      You will need to edit /etc/initramfs-tools/modules file by running sudo nano /etc/initramfs-tools/modules and add these two modules to booting process:

      i195
      nvme
      
    3. Changing GRUB2 options

      Change the grub2 booting options by running sudo nano /etc/default/grub and editing these lines:

      GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.preliminary_hw_support=1"
      GRUB_GFXMODE="1024x768"
      

      The last line is your preferred resolution, otherwise GRUB will use the maximum UHD resolution that is hard to read. Also, don’t use any 16:9 resolution as GRUB seems to have issues with those. Just use any 4:3 ratio screen resolution.

Now you will be able to boot into Ubuntu without an issue.

1

Problem

I was experiencing the same issue on a ThinkCentre m900 SFF with a i7-6700 CPU. The system would freeze randomly and a hard reset was required, which rendered working with that system a pain if not impossible. The log only showed a lockup state of the CPU, but did not provide extensive information as the logging was frozen as well.

Research

This issue is probably related to the power states the Skylake processor, which are not compatible with Kernels from the 4x series yet.

Solution Attempts

I tried setting the boot parameter intel_idle.max_cstate=1, as suggested here and here and here. This did not have a positive effect and the system continued to freeze every few hours.

I also installed newer kernels in Ubuntu 16.10, including Kernel 4.8 which should support the Skylake CPUs, but still the problem remained and the system freezed. I also tried Mint 18.0, Mint 18.1, Ubuntu 16.04 and Ubuntu 16.10. All systems showed the same behavior, which - in retrospective - was not surprising as they are all Xenial based, but I tried to exclude the Window Manager from being a cause. I disabled the on-board GPU and only used the Nvidia card and vice versa to exclude the GPU as a cause. I disabled UEFI and reinstalled with a legacy BIOS, same effect.

Workaround Solution

Lenovo certified the system for Ubuntu 14.04 officially, see here. As a last try, I reinstalled the older version of Ubuntu, which appeared before the CPU was released. I did not expect the 3.x Kernel to work, but as a surprise I am now running Mint 17.3 Rosa, based on Trusty (14.04.05 LTS) and have security updates until early 2019. I hope the problem is resolved until then, so far I had no more freezes.

protected by Pilot6 Feb 20 '16 at 14:39

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?