I recently upgraded from Kubuntu 14.10 to 15.10 (via 15.04) with Plasma 5.4. The migration from KDE SC 4 to Plasma 5 went rather smoothly (except for some weird hiccup while migrating kwallet... but that still kept working with all applications).

I am experiencing a problem setting up my Google Hangouts account with telepathy on my main workhorse machine. On a different machine with the same distro, it works.

I can add the Google account from System Settings -> Online Accounts via the Google Web UI Snippet. Clicking "configure" next to the account, crashes system settings, but that is a different bug entirely.

After adding the account, clicking the red human silhouette icon in the system tray and then on "go online" just leads to an error message telling me it cannot authenticate: "Authentication of your account failed (is your password correct?"

All the bug reports I found pertaining to this subject seem to say that "it works first, only to subsequently crap out with the message above." So that can't be it, since for me it doesn't work at all.

I compared all telepathy and kde-telepathy packages installed on both machines and they are identical.

In order to exclude a purely configurative problem, I set up a new user account on the problematic computer and tried to set up a new account there. That failed as well, with the same error message.

My suspicion is that the problem has something to do with the packages/config on the machine in question. But I do not know how to best debug this. Any help will be greatly appreciated. . Thanks

  • Here is a screen of the config options I get after adding the account, on the problematic machine: imgur.com/izV5JUP On the machine where it works I see multiple other options for the same Google account: picasa, hangouts, etc... Any ideas why this discrepancy exists? – dribnif Oct 29 '15 at 14:12
up vote 2 down vote accepted

Just for the sake of completeness, the problem had nothing to do with KWallet. Instead it was caused by this bug:

https://bugs.kde.org/show_bug.cgi?id=355415

Following the instructions of comment#19 I managed to patch the package. Should not be an issue on Kubuntu 16.04 or newer.

some weird hiccup while migrating kwallet

Thats probably the issue, check your password inside KWalletManager and make sure it is correct. You may need to reconfig kwallet

  • Thanks for your answer. That is what I suspect as well. I tried disabling KWallet completely, but that wouldn't work either. On the other hand, shouldn't the KWallet-config be user-specific? Which would in turn mean that it should work for a fresh user, with now kde4 baggage? Also, what exactly do you mean by reconfiguring kwallet? – dribnif Oct 29 '15 at 7:33
  • Have you checked you kwallet status by kwallet manager ? were passwords correct ? was your kwallet connected to telepathy in application tab ? Yes, kwallet cofig is user related and what i meant by "reconfig" was generally removing the .local/share/kwalletd contents. As you have checked it for a fresh user I suggest you to first make sure that kwallet is fully functional. – r3zaxd1 Oct 29 '15 at 12:36
  • 1
    I tried removing .local/share/kwalletd alltogether and it still doesn't connect. One problem I have with KWallet is that upon migrating, I changed the password. When I log in, all applications can use the wallet I open using the NEW password. When starting Chromium and/or Chrome, it prompts me to open KWallet again, and it only works with me OLD password. Might it be related to this? Any ideas, as to how I could unify these 2 wallets or force Chrome to use the new one? – dribnif Oct 29 '15 at 14:04

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.