15

i am trying to install a video script and I need to install FFmpeg with all the codecs. I have tried many tutorials online and I didn't succeed. FFmpeg (from SVN)

  • x264 Library for mencoder
  • Tell us what you tried and how it failed. – guntbert Mar 20 '17 at 18:47
38

To install it :

If you're using Ubuntu 14.04 :

ffmpeg was replaced in previous releases by the avconv program from the libav project.

To install avconv you need to install the libav-tools package:

sudo apt-get install libav-tools

Or use PPA :

sudo add-apt-repository ppa:mc3man/trusty-media
sudo apt-get update
sudo apt-get install ffmpeg gstreamer0.10-ffmpeg

If you're using Ubuntu 15.04 :

FFmpeg Returns To The Official Ubuntu Repositories With Ubuntu 15.04 Vivid Vervet.

Just type :

sudo apt-get install ffmpeg

For more info :

Is FFmpeg missing from the official repositories in 14.04?

Install FFmpeg on Ubuntu 14.10 Using PPA

| improve this answer | |
  • If i install it from the given ppa, will it be installed with all the codecs? – Arjon11 Oct 28 '15 at 16:48
  • @Arjon11, i'm not sure ! but if it doesn't work, you can take a look at MPlayer, or at How to install the transcoding tools on Ubuntu 14.04 – Bilal Oct 28 '15 at 21:20
  • 4
    And this seems to no longer work in 16.04 – matanster Jun 16 '16 at 11:55
  • 1
    FYI: libav-tools alone does not work on ubuntu 14.04 but the ppa does work. – e_x_p Mar 22 '18 at 8:22

Not the answer you're looking for? Browse other questions tagged or ask your own question.