0

I have Acer Aspire V13-371 and preinstalled Win10. It has BIOS v1.28. I set Hyperpass and disabled secure boot. I start it with Live USB key via Temp boot order and it works fine; it works even if I just change boot order in BIOS/uEFI with Live USB stick. So Live CD comes up and I choose erase entire disk and install Ubuntu, then choose other USB stick to have it installed on it (to have completly separated installation of Ubuntu on USB stick)...installation is completed with a success and after I reboot my laptop and have new, fresh USB Ubuntu stick inserted, I just see Win boot loader...I also tried to with this procedure, same result: uEFI only bootable USB If I do same procedure on my desktop, it just works smoothly... Any ideas? If I start Ubuntu with Live USB and then write in grub exit, I'm returned back to Loader when I can see new USB stick along with LIVE USB and Win boot loader...

0

First boot into your Windows installation and disable hibernation and Fast Boot.

Disable hibernation by opening command prompt as administrator and execute:

    powercfg /h off  

To disable Fast Boot open Control Panel (the old version - not the modern design),
select the Energy Settings, enable show hidden settings and uncheck Fast Boot.

Shut down the machine completely - do NOT reboot !

Reinstall the GRUB boot loader to your Ubuntu installation in EFI mode.

Boot from the Ubuntu installation media - open a terminal and execute:

    sudo mount /dev/sd*** /mnt
    sudo mount /dev/sd** /mnt/boot/efi
    for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
    sudo chroot /mnt
    grub-install /dev/sd*
    update-grub  

Note:

sd* = disk | sd** = efi partition | sd*** = system partition

To identify the partition numbers use GParted - it is included in the Ubuntu install media.

Boot into BIOS and select Ubuntu in UEFI settings as the default operating system to boot.

You now can select which operating system you want to boot from the GRUB boot menu.

0

I made it...looks like it was the problem in BIOS/uEFI parameters.. I was following this link as I thought that it is more of an BIOS/uEFI problem: Acer Aspire E15 will not dual boot

Thanks for the assist... BTW, I have Qualcomm Atheros QCA61x4 wireless network adapter in this laptop and followed this procedure: Qualcomm Atheros QCA61x4 wireless network adapter but it doesn't solve my issue... will there be any updates in a while for it or is it just too "exotic" that driver would be in the whole package?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.