I am new to Ubuntu, so not sure of anything yet.

But after upgrading to 15.10 I get this error 'intel pipe config compare i915 error mismatch in ips_enabled' after I the grub screen when I load Ubuntu.

Any help would appreciated.

  • Is that message the only problem?
    – Pilot6
    Oct 28, 2015 at 19:24
  • Maybe bug 1492764.
    – ubfan1
    Oct 28, 2015 at 20:20
  • 1
    well so far that is what I picked up and now I dont even get to the login screen
    – Darren
    Oct 29, 2015 at 8:12
  • I have the same problem. Really annoyed and quite unhappy with myself for upgrading.
    – Harel
    Oct 29, 2015 at 8:25
  • I was so excited for 15.10 since I am new to ubuntu. Still am though and really don't want to go back to windows.
    – Darren
    Oct 29, 2015 at 8:40

2 Answers 2


I ran into the same error. There are a couple of bug threads related to the errors I'm seeing and they claim to have fixed it in the nightly kernels.

dmesg shows "drm:gen8_irq_handler i915 ERROR The master control interrupt lied (SDE)!"

Intel Display i915 driver crashes, Asus Zenbook 303LA


The key to solve this issue (at least for me) was to remove the usage of nomodeset from /etc/default/grub (requires to manually execute sudo update-grub afterwards to actually apply the change). Rebooting the Intel i915 driver load normally.

Not the answer you're looking for? Browse other questions tagged or ask your own question.