1

I am trying to install Ubuntu 14.04 on Windows 10. While installing I formatted one data drive in Windows (E drive), chose 8GB of those as swap area and allocated all the remaining free space to install ubuntu (by chosing ext4 file system & mount point as /). Ubuntu is successfully installed.

But when I restart the system I am not getting an option to chose windows or Ubuntu. It is directly going to open Ubuntu.

The output of $ sudo fdisk -l command is

click here for the output

What might be the problem in the installation? How to resolve this?

Thanks in advance.

  • Will you show the output of $ sudo fdisk -l in your question. What is your reference to "E" drive. Are you saying "E" as in the 5th of five physical individual hard drives? The output of the command will probably answer that confusing component of your question.. – L. D. James Oct 28 '15 at 6:38
  • may help you ubuntuforums.org/showthread.php?t=1914570 – vjnan369 Oct 28 '15 at 6:40
  • E drive is one of the partition in my windows system. @L.D.James – Shiva N Oct 28 '15 at 6:53
  • There's no indication in your message that you have Windows installed on your computer. If you gave the output of $ sudo fdisk -l in your question it would add clarity to the confusion. The answer to your question, based on what you have presented, you only see Ubuntu because that is all that you have installed on your computer. After adding Ubuntu you would have Ubuntu and Windows as a boot option if Windows was actually installed on your computer. – L. D. James Oct 28 '15 at 7:01
  • I have added the output @L.D.James – Shiva N Oct 28 '15 at 7:10
1

You can run the following command which will search all the attached drives and partitions and add them to the grub menu:

$ sudo update-grub

After running the command from the console reboot the computer.

If you don't see the menu after rebooting run this command and show us the output. It would be easier to read a copy and paste of the output to your question (not a link to an image). You can select the text and click on the "{}" icon on the editor to give the proper format.

$ egrep "^menuentry"  /boot/grub/grub.cfg

For example the output of this command on my computer is:

menuentry 'Ubuntu' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-3ebc689f-aa43-4ea1-a9b9-5e8d9e6d92af' {
menuentry 'Memory test (memtest86+)' {
menuentry 'Memory test (memtest86+, serial console 115200)' {
menuentry 'Ubuntu 15.10 (15.10) (on /dev/sda1)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-simple-a13034ce-00a0-4bd2-8188-f780137413d7' {

There isn't a Windows entry on my system because Windows isn't installed. If you have windows installed on your system we will see it in the automatically created grub.cfg file.

  • sudo update-grub solved my problem. Thanks – Shiva N Oct 28 '15 at 10:17
0

You have to go on Ubuntu and run:

sudo add-apt-repository ppa:danielrichter2007/grub-customizer
sudo apt-get update
sudo apt-get install grub-customizer

Then launch Grub Customizer and it will install grub automatically with Ubuntu - Windows options. You can also rename, add and delete some entry on your grub.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.