0

I've had Ubuntu installed for years on other pieces of hardware, and I've just recently purchased a Thinkpad x201 Tablet edition.

Thing is, I've been using the laptop for months now with no problems, the problem came up when i tried to install a game that requires OpenGL3, which should be no problem based on my hardware. Come to find out: Ubuntu has my graphics card listed as an Ironlake-era Mobile card. Upon researching, I found out that I actually have Intel Integrated HD Graphics on my i7 L640 cpu, which is a Sandy Bridge model, which fully supports OpenGL3. I've tried updating the drivers using the Intel Installer, but it hangs on committing a certain part. (I'd try to replicate this, but the whole process can be a pain, I've got to manually kill the process, restart into terminal mode and fix a a few things on the backend before I can get back into my system).

I'm currently upgrading to 15.10 with hopes that there might be some more stability, so that I can hopefully rerun the graphics driver installer without a hitch.

Just wondering if someone else knew how to deal with this problem. Overall, this is just a minor gripe, but it's something that I'd like to see taken care of.

Thanks for your help!

Robert Edwards

1

Your CPU is Westmere architecture and not SandyBridge and does not support OpenGL 3.0.

There are no additional drivers you need to install for this GPU with Ubuntu. The drivers included in Ubuntu provide full support.

  • I believe I spent an hour searching for information about the wrong CPU. Thank you for setting me straight. – Robert Edwards Oct 27 '15 at 20:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.