0

I hope you can help me. I am upgrading to ubuntu 15.10 from 15.04 following the process described here http://www.ubuntu.com/download/desktop/upgrade. In the Installing the upgrades process and almost at the end the process it got stuck with a error message E:Sub-process /usr/bin/dpkg returned and error code (1)

If i try sudo dpkg --configure -a i get

dpkg: dependency problems prevent configuration of evince:
 evince depends on evince-common (>= 3.16); however:
  Version of evince-common on system is 3.14.2-0ubuntu2.

dpkg: error processing package evince (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of brasero:
 brasero depends on brasero-common (= 3.12.1-0ubuntu2); however:
  Version of brasero-common on system is 3.12.0-0ubuntu2.

dpkg: error processing package brasero (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libbrasero-media3-1:
 libbrasero-media3-1 depends on brasero-common (= 3.12.1-0ubuntu2); however:
  Version of brasero-common on system is 3.12.0-0ubuntu2.

dpkg: error processing package libbrasero-media3-1 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of rhythmbox-plugin-cdrecorder:
 rhythmbox-plugin-cdrecorder depends on libbrasero-media3-1 (>= 3.0.0); however:
  Package libbrasero-media3-1 is not configured yet.

dpkg: error processing package rhythmbox-plugin-cdrecorder (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ubuntu-desktop:
 ubuntu-desktop depends on evince; however:
  Package evince is not configured yet.

dpkg: error processing package ubuntu-desktop (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of brasero-cdrkit:
 brasero-cdrkit depends on libbrasero-media3-1 (= 3.12.1-0ubuntu2); however:
  Package libbrasero-media3-1 is not configured yet.

dpkg: error processing package brasero-cdrkit (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 evince
 brasero
 libbrasero-media3-1
 rhythmbox-plugin-cdrecorder
 ubuntu-desktop
 brasero-cdrkit

That is what I am getting in the Upgrade Dialog

enter image description here

Thanks in advance

  • 1
    Try a sudo apt-get install -f – A.B. Oct 27 '15 at 15:44
  • Tried but no success. I get the following message Errors were encountered while processing: /var/cache/apt/archives/brasero-common_3.12.1-0ubuntu2_all.deb /var/cache/apt/archives/evince-common_3.16.1-0ubuntu1_all.deb E: Sub-process /usr/bin/dpkg returned an error code (1) – mario martinez Oct 27 '15 at 15:49
0

You may wish to perform a a fresh install and restore your data from backup.

You did perform a a backup before you started the upgrade ? If not, start with a backup.

If you wish to try to upgrade anyways, I suggest you remove all those broken packages.

sudo apt-get purge evince brasero libbrasero-media3-1 rhythmbox-plugin-cdrecorder ubuntu-desktop brasero-cdrkit

Then re-try your upgrade and re-install those packages after the upgrade.

sudo apt-get install evince brasero libbrasero-media3-1 rhythmbox-plugin-cdrecorder ubuntu-desktop brasero-cdrkit

If you get errors, you can try to manually remove the packages, one at a time if necessary

sudo dpkg --remove --force-all evince

If you still get errors you will need to manually remove the package

cd /var/lib/dpkg/info
sudo rm evince.*

Re-run the upgrade, install the packages you removed

sudo apt-get install evince brasero libbrasero-media3-1 rhythmbox-plugin-cdrecorder ubuntu-desktop brasero-cdrkit

See the apt-get and dpkg man pages and/or http://blog.bodhizazen.com/linux/apt-get-how-to-fix-very-broken-packages/ for details on those commands.

  • I am trying to continue with the upgrade process, backup was already made it. Do i need to close Distribution Upgrade dialog window in order to follow your recommendations? – mario martinez Oct 27 '15 at 16:18
  • Yes, close/abort the upgrade window. – Panther Oct 27 '15 at 16:26
  • I followed the recommendations i had to remove one by one. After I tried to install the packages again but at the end i get Errors were encountered while processing: /var/cache/apt/archives/brasero-common_3.12.1-0ubuntu2_all.deb /var/cache/apt/archives/evince-common_3.16.1-0ubuntu1_all.deb E: Sub-process /usr/bin/dpkg returned an error code (1) – mario martinez Oct 27 '15 at 17:26
  • Do you think should i try the upgrading process again? – mario martinez Oct 27 '15 at 17:27
  • You have to manually remove the packages, then re-run the upgrade. – Panther Oct 27 '15 at 18:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.