2

I'd appreciate some insight. I've tried Charles's workaround here: VMware won't work after Ubuntu Upgrade which passes the first hurdle and I get a Kernel upgrade message, but then it fails to update Kernel ... fails on Vmnetwork. Output of CLI below:

Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: cannot open shared object file: No such file or directory

failed
make[1]: *** [_module_/tmp/modconfig-TrwoH8/vmnet-only] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-4.2.0-16-generic'
Makefile:120: recipe for target 'vmnet.ko' failed
make: *** [vmnet.ko] Error 2
make: Leaving directory '/tmp/modconfig-TrwoH8/vmnet-only'
Starting VMware services:
   Virtual machine monitor                                             done

   Virtual machine communication interface                             done

   VM communication interface socket family                            done

   Blocking file system                                                done

   Virtual ethernet                                                   failed

   VMware Authentication Daemon                                        done
2
  • Saw your note here TonyM - I thought you were workstation 12... Workstation 11 needs some patches to compile properly - they can be downloaded from github and run into your system. The github link has complete instructions. There are also some notes for kernel 3.19 which are still applicable. Oct 27 '15 at 15:20
  • Thanks Charles. Yip, I did have WKS 11. I used your fix for WKS 12 and it works. Thanks.
    – Tony M
    Oct 31 '15 at 4:27
1

I solved it doing.

after kernel 4.4 (VMWare Workstation 12) need some changes in c code:

/usr/lib/vmware/modules/source

1) vmmon.tar

  • untar

  • change ./vmmon-only/linux/hostif.c

  • replace all:

    "get_user_pages" to "get_user_pages_remote"

  • tar and replace original

2) vmnet.tar

  • untar

  • change ./vmnet-only/userif.c

  • replace all:

    "get_user_pages" to "get_user_pages_remote"

  • tar and replace original

Successful compiled on FC23 FC24, FC25 (kernel 4.7)

https://communities.vmware.com/message/2598402#2598402

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.