6

Good day everyone,

I just upgraded to Ubuntu 15.10 using the Software Updater. After reboot I realized that Enigmail (Version 1.2.8.) in Thunderbird (Version 38.3.0) stopped working. I am unable to sign or encrypt mails.

When Enigmail uses gpg (GnuPG) 1.4.18 the following error window appears immediately after pressing the Send button:

Send operation aborted.
Error - bad passphrase

I never even got the dialog to enter the passphrase. For testing I installed gpg (GnuPG) 2.0.28, reinstalled Enigmail and configured it to use gpg2. When adjusting the settings in Preferences -> Basic Settings the following error appeared:

Cannot connect to gpg-agent.
Maybe your system uses a specialized tool for passphrase handling
(e.g. gnome-keyring, seahorse-agent, KDE wallet manager, ...).
Unfortunately Enigmail cannot control the passphrase timeout for the tool you are using.
Therefore the respective timeout settings in Enigmail are disregarded.

When trying to send a signed or encrypted mail using gpg2 I get a different error message:

Send operation aborted.
Key 0xXXXXXXXX not found or not valid.
The (sub-)key might have expired

That is simply not true. The keys are present and they have not expired. Curiously, the Enigmail key manager does display the keys correctly.

The underlying problem seems to be with gpg-agent (gpg-agent (GnuPG) 2.0.28). Checking if the agent is running:

> ps ax | grep gpg
6971 ?        Ss     0:00 gpg-agent --daemon

Trying to connect:

> gpg-agent
gpg-agent: can't connect to the agent: IPC connect call failed

> sudo gpg-agent
gpg-agent: no gpg-agent running in this session

Trying to sign a file:

> gpg -s test.txt
[user and key info]
can't connect to `/tmp/gpg-GBtHXS/S.gpg-agent': No such file or directory
gpg: can't connect to `/tmp/gpg-GBtHXS/S.gpg-agent': connect failed

TL;DR;

Apparently gpg-agent is not working anymore. My Questions are:

  • Why is gpg-agent not working anymore?
  • How can this be fixed?

Thanks everyone for your time and insight.

Software versions summary:

  • gpg (GnuPG) 1.4.18
  • gpg (GnuPG) 2.0.28
  • gpg-agent (GnuPG) 2.0.28
  • Enigmail 1.2.8.
  • Thunderbird 38.3.0
  • Ubuntu 15.10 wily werewolf
4

I had a similar problem and solved it by installing pinentry-gnome3 (I'm using Gnome Shell, not Unity):

sudo apt-get install pinentry-gnome3
  • 1
    well, I've got pinentry-gnome3 installed, but still seeing this bug of gpg-agent not running, giving the error "gpg-agent: no gpg-agent running in this session". This is also with 15.10 Wily, using Gnome-Shell just as you indicate. Any other advice? – rik-shaw Nov 5 '15 at 16:51
  • 1
    That did indeed fix it for me. Thank you! I am using unity BTW. – T32ET Nov 20 '15 at 7:52
  • This is already installed and does nothing for me on 15.10 Wiley, using Unity. – SinaCutie Feb 27 '16 at 6:56
2

I got it partially working again. For anybody interested, here is what I did.

  • Removed Enigmail
  • Removed GPG2
  • Reboot
  • Reinstall GPG2
  • Reinstall and configure Enigmail
  • Reboot

Encrypting now works as before. However, Signing of messages still fails with above error message (key invalid ...).

The GPG Agent now works as expected from command line. Enigmail still does not prompt me for the passphrase and still reports a missing or invalid key.

EDIT: changed answer, since it was premature

  • Have exactly the same issue since I upgraded to 15.10 Your fix did not solve it for me. Any suggestions? – Juke Oct 28 '15 at 15:30
0

Solved the problem by adding

use-agent

to .gnupg/gpg.conf

gpg-agent was not running by default after installation.

protected by Community Mar 15 '16 at 4:00

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.