1

I am running postgresql 9.4 ("PostgreSQL 9.4.4 on x86_64-unknown-linux-gnu, compiled by gcc (GCC) 4.1.2 20070626 (Red Hat 4.1.2-14), 64-bit" )

when I am trying to create language in postgres SQL :

create language plpythonu;

then it gives following error :

ERROR: could not access file "$libdir/plpython2": No such file or directory SQL state: 58P01

and i try this command :

sudo apt-get install postgresql-contrib-9.4 postgresql-plpython-9.4 

also try sudo apt-get install postgresql-plpython-9.4 but no luck . its giving result is :

    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
     postgresql-plpython-9.4 : Depends: postgresql-9.4 (= 9.4.5-1.pgdg12.4+1) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

Output of aptitude search plpython command is :

p   postgres-xc-plpython          - PL/Python procedural language for Post 

p   postgres-xc-plpython:i386     - PL/Python procedural language for Post 

v   postgresql-plpython           -                           

v  postgresql-plpython:i386      -                                    

p    postgresql-plpython-8.2      - PL/Python procedural language for Post 

p  postgresql-plpython-8.2:i386  - PL/Python procedural language for Post 

p  postgresql-plpython-8.3       - PL/Python procedural language for Post 

p   postgresql-plpython-8.3:i386  - PL/Python procedural language for Post 

p   postgresql-plpython-8.4       - PL/Python procedural language for Post 

p  postgresql-plpython-8.4:i386  - PL/Python procedural language for Post 

p  postgresql-plpython-9.0       - PL/Python procedural language for Post 

p   postgresql-plpython-9.0:i386  - PL/Python procedural language for Post 

p  postgresql-plpython-9.1       - PL/Python procedural language for Post 

p  postgresql-plpython-9.1:i386  - PL/Python procedural language for Post 

p  postgresql-plpython-9.2       - PL/Python procedural language for Post 

p  postgresql-plpython-9.2:i386  - PL/Python procedural language for Post 

p  postgresql-plpython-9.3       - PL/Python procedural language for Post 

p  postgresql-plpython-9.3:i386  - PL/Python procedural language for Post 

p  postgresql-plpython-9.4       - PL/Python procedural language for Post 

p  postgresql-plpython-9.4:i386  - PL/Python procedural language for Post 

p  postgresql-plpython-9.5       - PL/Python procedural language for Post 

p  postgresql-plpython-9.5:i386  - PL/Python procedural language for Post 

v postgresql-plpython3          -                                    

v  postgresql-plpython3:i386     -                                    

p  postgresql-plpython3-9.1      - PL/Python 3 procedural language for Po 

p  postgresql-plpython3-9.1:i386 - PL/Python 3 procedural language for Po 

p  postgresql-plpython3-9.2      - PL/Python 3 procedural language for Po 

p  postgresql-plpython3-9.2:i386 - PL/Python 3 procedural language for Po 

p  postgresql-plpython3-9.3   - PL/Python 3 procedural language for Po 

p  postgresql-plpython3-9.3:i386 - PL/Python 3 procedural language for Po 

p  postgresql-plpython3-9.4      - PL/Python 3 procedural language for Po 

p  postgresql-plpython3-9.4:i386 - PL/Python 3 procedural language for Po 

p  postgresql-plpython3-9.5      - PL/Python 3 procedural language for Po 

p  postgresql-plpython3-9.5:i386 - PL/Python 3 procedural language for Po
6
  • 1
    The installation of postgresql-plpython-9.4 is blocked, because the package depends on postgresql-9.4 (= 9.4.5-1.pgdg12.4+1) and this version isn't installable in your system. Why? Edit your question and add the output of apt-cache policy postgresql-plpython-9.4 postgresql-9.4; sudo apt-get install postgresql-9.4. And please explain this Red Hat 4.1.2-14 =) – A.B. Oct 27 '15 at 7:45
  • x-posted from stackoverflow.com/q/33361867/398670 – Craig Ringer Oct 27 '15 at 7:46
  • @A.B. when I execute select version() command on postgres then it gives PostgreSQL 9.4.4 on x86_64-unknown-linux-gnu, compiled by gcc (GCC) 4.1.2 20070626 (Red Hat 4.1.2-14), 64-bit so i put in the question i think it will help . – Shubham Batra Oct 27 '15 at 7:49
  • @CraigRinger this same question i placed on stackoverflow – Shubham Batra Oct 27 '15 at 7:51
  • Yes, I know. I have posted links between them to stop people wasting their time asking the same followup questions, doing the same followup edits, posting the same answers, etc. If you post duplicates, please at least link between them to save everyone some time. – Craig Ringer Oct 27 '15 at 7:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.