I've downloaded some updates for Ubuntu 11.10 and, after I restarted my computer to the changes take effect, I've realized that the Unity interface was not working properly. The left panel (where the apps stay), and the top bar was also not appearing. I've restarted my computer again but the things stood the way they were.

Well, then I tried to force Unity to run via terminal, but when I try unityor unity --reset, the first message that appears is "unity-panel-service: process not found". When I type unity-panel-service on terminal, it also says it is not found.

Then I searched about it on the web and got this page (http://manpages.ubuntu.com/manpages/oneiric/man1/unity-panel-service.1.html) which says that unity panel service is the process responsible for loading the panels that are missing.

So, my question is, how can I re-download or reinstall it so unity can work again? Or, of course, if I'm wrong and the reason unity is not working is not that, please tell me :)

3 Answers 3


I had a similar issue due to a broken graphics driver which didn't go away when I reinstalled fglrx. I eventually stumbled upon the solution: The unity plugin had been disabled in the compiz settings!

Fixed by running ccsm then enabling the Unity plugin and disabling any conflicts.

  • For me, unity plugin was conflicting with gnome compatibility plugin.
    – NimsDotNet
    Apr 20, 2012 at 2:21

I had the same issue. Had fiddled around with ccsm for a bit and downloaded some updates, then after rebooting unity 3D no longer worked. Missing launcher and panel.

unity --reset didn't help and I had to use Ubuntu 2D (this option was deprecated since Ubuntu 12.10).

Thanks to your link, I found unity-panel-service in /usr/lib/unity/unity-panel-service. I used dpkg-query -L unity-services after finding the package name in the man page you linked. That gives you the location of all its contents.

I then ran /usr/lib/unity/unity-panel-service while logged into 2D. I didn't expect that to work, and it doesn't. It exits with a fatal error, saying it cannot register itself. Not surprising, since there already is a panel, I guess. However, after the failed start in 2D, I can suddenly log into 3D again and everything is back to normal. Hope that works for you, too.

If you don't have /usr/lib/unity/unity-panel-service, then I'd try removing and re-installing the unity-services package, which provides that executable.

  • Does not work for me.
    – Daniel
    Dec 2, 2015 at 12:12

Nothing of the other replies worked for me. I did something more simple. I create a new user (called temporal)

sudo adduser temporal
sudo adduser temporal root
sudo adduser temporal admin 

(this is useful to write the file in your normal user space)

Close session and enter in temporal.

(If you don't have access to the normal menu you can execute in terminal:

killall -u your-user


Once you have entered "temporal" session execute ccsm (compizconfig settings manager) in a terminal (Control+Alt+T):

ccsm &

Go to Preferences → Export "fix.profile"

Close temporal session. Open your session. Open ccsm.

ccsm &

Go to Preferences → Import your file "fix.profile".

You will have again your Unity 3D bar.

Delete the temporal session:

sudo deluser temporal

Remove the files:

sudo rm -rf /home/temporal


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .