This question already has an answer here:

I went ahead and upgraded from Mint 17.2 to Ubuntu 15.10 on my Acer ES1-511-P1T9 with Bay Trail n3530 CPU and so far am having amazing performance over Mint 17.2 (almost 70-80% performance increase) however the system has started freezing. It seems to be when hitting the 4gb+ of memory in use (8gb installed). I've run a full memtest (about 3-4 hours) on the 8gb stick and am not seeing any errors. I've read a few things about issues with the new Intel HD linux drivers causing issues, has anyone else seen this with the Bay Trail CPUs? I'm hesistant to pull the 8gb and reinstall the 4gb as its such a pain removing the whole motherboard to do so lol if there is any chance that it's something else.

Edit: Under 8.1 Pro x64 system is fully stable. Under 15.04 system is fully stable however performance is horrible (actually worse than under Win8.1). Fresh install of 15.10 yields a freeze usually within 10 minutes even with 0 applications running and wifi disabled. This sucks :( I don't want to use Win8.1 lol

marked as duplicate by Zanna, jokerdino Sep 13 '16 at 13:08

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I'm reinstalling 8.1 x64 right now and load test the thing and report back whether its RAM or GPU driver. – Scott Inan Oct 27 '15 at 1:57

I had the EXACT same problem under MATE-15.10. Running the 15.04 base was perfect but with the new 15.10 wonderful increases all over really pushed me to change. I have an Acer Aspire with the Bay Trail and N3540 Processor. (4 identical laptops) I have experienced the same freezing. The Kernel logs absolutely nothing and the freezing occurs completely in random, in use or just idle. First time it happened was only a few minutes in and continued to happen anywhere from 5 minutes to a few hours. No logging occurs at all, everything is 100% unresponsive including the Kernel. No SysRq commands go through at all.

After a few frustrating nights of trying tons of fixes it was still a problem. I believe it has something to do with the power management in the newer 4.2 Kernel. I noticed when the system freezes that the processor starts to heat up and stays toasty even though the system is dead.

I finally decided to try stepping back Kernels. I have 4 identical laptops so I was able to do a 100% unmodified fresh install of Mate 15.10 each time before testing. ALL 4 laptops experienced the same random system freezing. The first Kernel I used before the 4.2.x ran stable as could be.

I'm convinced the issue is in the 4.2 Kernel and I was able to solve my problem by reverting back to Kernel 4.1.20. Not only are all the speed increases still present but the system is running better than it's ever ran before on a Ubuntu Build. As a very experienced and serious Linux user it's always exciting when LEAPS are made over little steps.

TO REVERT The Kernel I did the following: (Partially Taken from http://linuxdaddy.com/blog/install-kernel-4-1-on-ubuntu/ for reference to the Kernel Files I needed)

Open a Terminal Window: mkdir /tmp/kernel cd /tmp/kernel wget \ kernel.ubuntu.com/~kernel-ppa/mainline/v4.1.20-wily/linux-headers-4.1.20-040120_4.1.20-040120.201603171731_all.deb \ kernel.ubuntu.com/~kernel-ppa/mainline/v4.1.20-wily/linux-headers-4.1.20-040120-generic_4.1.20-040120.201603171731_amd64.deb \ kernel.ubuntu.com/~kernel-ppa/mainline/v4.1.20-wily/linux-image-4.1.20-040120-generic_4.1.20-040120.201603171731_amd64.deb

//Make sure you copy the entire WGET command from \ to the last line as it will download all of the files in one shot.

Install the Kernel: sudo dpkg -i linux-headers-4.1*.deb linux-image-4.1*.deb

Kernel Installation is DONE. Now to USE the Kernel you will need to modify your GRUB Configuration. To do so, RESTART your computer, After your BIOS screen hold the SHIFT key to get the GRUB Boot Options. From here you will need to pay attention to the menu options. Imagine an imaginary number next to each menu line starting with ZERO, 1, 2, 3.

Mine looked like this.

0) Ubuntu

1) Other Versions

2) Mem Test

3) Mem Test 2

After selecting 1. Other Versions I came to the Kernels Screen. I had done a full system update which installed other Kernels So My screen had several. Imagining the numbers again.

0) Kernel 4.2.0-34

1) Kernel 4.2.0-34 Safe

2) Kernel 4.2.0-16

3) Kernel 4.2.0-16 Safe

4) Kernel 4.1.20

5) Kernel 4.1.20 Safe


So to select the slightly older Kernel that works perfect it was option 4.

REMEMBERING these numbers, go ahead and SELECT the 4.1.20 Kernel to boot from. Once the system has started Open a Terminal.

cd /etc/default sudo edit grub (use whatever editor you have to change the file)

You will need to modify the first line to look like this GRUB_DEFAULT="1>4"

REPLACING 1 and 4 with whatever numbers corresponded to your menu options. Make sure to remember the quotes. This line will tell grub to select menu 1 and sub menu 4 which will be the kernel we installed.

After savings the file run:

sudo update-grub

You're Done with the hard part! I ran into one other issue which you may or may not run into with the 4.1 series Kernels. There was always a problem with rebooting time. The user session would default to 90 seconds before closing processes. Thankfully you don't reboot too often, but to fix that make the following change.

Open a Terminal:

cd /etc/systemd sudo edit system.conf

FIND and remove the # comments for these two lines. DefaultTimeoutStartSec=10s DefaultTimeoutStopSec=10s

Note that I changed the time to 10s which is what you will want to do. The default is 90s. This will cause the user session to terminate in the 10s version waiting 90s. (or so it would seem). Save this file and restart. To see proof of the change pressing escape on the splash page will show you the commands running through the restart process.

ALL DONE! In my 18 years of using linux both personally and professionally. The MATE 15.10 Build on Ubuntu with the 4.1.20 Kernel has been the most successfully complete system running and I run a LOT of machines of every shape, size, age and profession for hundreds of companies. Hope this helps others!

p.s. Something I believe worth mentioning. On the INTEL BAY TRAIL CPU's I've NEVER been able to run the USB 3.0 Mode enabled in the BIOS without problems on any linux Kernel in the last several years. So I would just make sure you keep the Enhanced USB 3.0 DISABLED when running Linux. It will work but I experienced data loss, device issues and shutdown and reboot problems and power management issues with this option enabled.

  • Using the 4.1.20 kernel worked for me, though I removed newer kernels with apt-get and used synaptic to lock 4.1.20. – Marc Jul 19 '16 at 13:42


sudo nano /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_idle.max_cstate=1"

  • ... and then sudo update-grub... Also please explain what is being changed by this. – s3lph Dec 9 '15 at 21:43
  • worked for me .... no freezes for 4 days now – David Walker Jan 29 '16 at 10:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.