I upgraded my ubuntu gnome installation to 15.10 and everything is kinda good except for the touchpad single-tap functionality. Single-tap-to-click is not working. And I have tried all possible solutions like editing synaptics.conf file.

One thing that I noticed is the following, which is kinda strange. For every input device the schema has an original and deprecated entry but for touchpad it just has deprecated. Is this the cause?

I don't know how to resolve this issue. Please help!


Below is the screenshot of my mouse&touchpad settings: enter image description here

Also, my synclient results are like,

$ synclient | grep TapButton

TapButton1   = 0  
TapButton2   = 0  
TapButton3   = 0  

my xinput command yields the following,

$ xinput list
Virtual core pointer              id=2  [master pointer  (3)]  
 ↳ Virtual core XTEST pointer        id=4   [slave  pointer  (2)]  
 ↳ SynPS/2 Synaptics TouchPad        id=12  [slave  pointer  (2)]  
 ↳ MCE IR Keyboard/Mouse (ene_ir)    id=13  [slave  pointer  (2)]  
Virtual core keyboard             id=3  [master keyboard (2)]  
 ↳ Virtual core XTEST keyboard    id=5  [slave  keyboard (3)]  
 ↳ Power Button                   id=6  [slave  keyboard (3)]  
 ↳ Video Bus                      id=7  [slave  keyboard (3)]  
 ↳ Power Button                   id=8  [slave  keyboard (3)]  
 ↳ Sleep Button                   id=9  [slave  keyboard (3)]  

Results of xinput list-props 12 command:

Xinput list-props result

  • Answers here suggest that your touchpad may be recognised as a mouse. Some of the solutions listed could help – christopherlovell Oct 27 '15 at 10:37
  • I don't think that's the problem. I updated the question with 'xinput' output. Please see! – kmario23 Oct 27 '15 at 11:20
  • Did you try any of the approaches in the link? xinput has obviously identified the touchpad, but gnome hasn't, so the synaptics drivers are probably functioning incorrectly or are not linked – christopherlovell Oct 27 '15 at 11:28
  • I tried all of the fixes but nothing works for me :( – kmario23 Oct 27 '15 at 12:41
  • 1
    Why post a picture? You could post it as text. And it is not full. – Pilot6 Oct 28 '15 at 18:59

10 Answers 10


Open a terminal by pressing ctrl+alt+t and type:

synclient TapButton1=1 TapButton2=3 TapButton3=2

it worked for me...

  • Thanks! But it doesn't work after a reboot. is there a way to make it permanent? – kmario23 Nov 19 '15 at 17:51
  • @kmario23 at a guess, you'll need to set synaptics driver module options. Unfortunately I'm on mobile and can't easily confirm that or look up how to do it, but hopefully that gives an idea where to start. – Darael Nov 20 '15 at 10:38
  • Thanks! This answer helped me make it persistent: askubuntu.com/a/772094 – Gabe Kopley Jun 7 '16 at 22:17

I finally found a fix to solve my problem:

I added the following line to my bashrc so that it can compile every time I log in.

synclient TapButton1=1 TapButton2=3 TapButton3=2

Although not a pretty hack, but it works fine. Hope the community fixes the bug..

Update: This hack seems to work fine in Ubuntu 17.04 also, which means the bug isn't fixed yet by the community.

P.S. Also see this great solution

  • 2
    since you have found a working setting it is better way is to override synaptics touchpad configuration at /etc/X11/xorg.conf.d/70-synaptics.conf as outlined here – mzzzzb Jul 23 '16 at 15:14
  • Brilliant, this worked Ubuntu 17.04 – Ben Winding Apr 18 '17 at 9:31

Have you updated the mouse settings? After updating I had the same issue, but it was just that tap to click had been disabled.

mouse and touchpad settings

Otherwise, according to this thread it could be worth logging out and back in.

  • Thanks! But I don't see those three options[tap to click, two finger scroll, natural scrolling] under touchpad. But scrolling and everything works fine but tap-to-click does not – kmario23 Oct 27 '15 at 10:03
  • can you please tell me the procedure to update the settings? – kmario23 Oct 27 '15 at 10:16
  • move your mouse to the top right, click on the settings button, go to mouse & touchpad , settings should be there – christopherlovell Oct 27 '15 at 10:18
  • I don't see that option there. Please see updated question. – kmario23 Oct 27 '15 at 10:26

I had same problem in Ubuntu GNOME 16.04 and solved it with similar technique mentioned in Eliah Kagan's answer which was adapted from a comment but with some differences:

  1. Launch "dconf Editor" app. (if not installed, run: sudo apt-get install dconf-tools)

  2. Go to: org→gnome→desktop→peripherals→touchpad

  3. Enable tap-to-click.

  • works like a charm!! – kmario23 Mar 3 '18 at 17:57
  • I met a similar problem after installing 18.04. It seems that since my mouse was connected during install, the system saw touchpad as a mouse also. Editing the wanted settings with this method and rebooting without my mouse connected fixed it. – Al F Nov 5 '18 at 11:14

I had same problem, after I upgraded to ubuntu GNOME wily werewolf. so I make custom shortcut in keyboard for getting back functionality of touchpad, just fill synclient TapButton1=1 on command also fill the name form then choose your favorite keyboard combinations. it's fine enough for a while and wait for update.


I just upgraded to Ubuntu 17.04, a few days ago and face the same issues. This does the trick:

    sudo apt install xserver-xorg-input-synaptics

It only needs to download this stuff, nothing else.


In the settings window allows users to setup the mouse. But I need to configure the touchpad. The console helps to first reboot or sleep "synclient tapbutton1 = 1"

As I understand it, the system incorrectly identifies the device,It looks like a bug.


Give this a try, it worked for me on UbuntuGnome 15.10 so i made an entry in startup applications.

Using your favorite editor, create a script with the following contents and save it as e.g. touchpad.sh.


xinput --set-prop --type=int --format=32 "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Pressure" 4

# Below width 1 finger touch, above width simulate 2 finger touch. - value=pad-pixels
xinput --set-prop --type=int --format=32 "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Width" 8

# vertical scrolling, horizontal scrolling - values: 0=disable 1=enable
xinput --set-prop --type=int --format=8  "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Scrolling" 1 1

# vertical, horizontal, corner - values: 0=disable  1=enable
xinput --set-prop --type=int --format=8  "SynPS/2 Synaptics TouchPad" "Synaptics Edge Scrolling" 0 0 0

# stabilize 2 finger actions - value=pad-pixels
xinput --set-prop --type=int --format=32 "SynPS/2 Synaptics TouchPad" "Synaptics Jumpy Cursor Threshold" 250

# pad corners rt rb lt lb tap fingers 1 2 3 (can't simulate more then 2 tap fingers AFAIK) - values: 0=disable 1=left 2=middle 3=right etc. (in FF 8=back 9=forward)
xinput --set-prop --type=int --format=8  "SynPS/2 Synaptics TouchPad" "Synaptics Tap Action" 0 0 0 0 1 2 3   


Make the script executable:

chmod +x touchpad.sh

Now run the script and see if it works.

Original Information found here: http://www.mepis.org/docs/en/index.php?title=Configuring_the_touchpad_with_xinput

  • thanks! But if i do that, tap to click works but scrolling doesn't. any suggestions? – kmario23 Nov 18 '15 at 4:16

As an end user, the easiest way I found is to change to " Primary button" right click in mouse touchpad settings.

Double tap still works as primary left, tap in the button area works as right tap.

Ubuntu 17.04.


I have created a script to automate this process. It will be automatically started when the system starts. So, you don't have to run the same command again and again. The link of the script is github.com/Ryko-git/click-on-touchpad .

The installation process is very easy. It is given on the github page.

Not the answer you're looking for? Browse other questions tagged or ask your own question.