5

After upgrading my ubuntu server 15.04 to 15.10, it won't boot anymore. After starting the machine, it enters the BIOS. Selecting the linux drive to boot in UEFI mode just returns me back to the BIOS main menu instantly. Selecting it to boot in non-UEFI mode nets me a black screen with blinking curser.

Boot Repair tells me that grub (and everything else it might be checking) is in order.

The Ubuntu system is installed as UEFI and is the only OS present on this machine. The exact same thing happened on the previous release upgrade, at which point I just reinstalled Ubuntu get get stuff going again. Seeing as this might be a recurrent problem on my machine, I would be happy about any pointers as to where I could look for the source of the problem.

I am running this on an ASUS Motherboard, AMD CPU, Ubuntu Partition on a USB3 external HDD.

Big thanks in advance to any and all that might be able to shed some light on this.

1
  • I went thru the exactly same problem. This is the second time that the installation fails to upgrade the boot loader. The first time was a simple dist-upgrade on a clean installation of 15.04. There's something not very reliable in this grub upgrading/updating script.
    – Vinicius
    Dec 4 '15 at 12:35
2

Maybe something went wrong when it came to installing the boot loader.

Reinstall the GRUB bootloader to your Ubuntu installation in UEFI mode.

Boot from the Ubuntu install media - execute the following commands :

sudo mount /dev/sd*** /mnt
sudo mount /dev/sd** /mnt/boot/efi
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
sudo chroot /mnt
grub-install /dev/sd*
update-grub  

Note : sd* = disk | sd** = efi partition | sd*** = system partition

To identify disks and partitions you can use any Linux Live (DVD/USB) media containing (g)parted.

2
  • This indeed solved the problem and got my system back up and running. I guess in half a year, when the next release is here, I will see if it also fixed the underlying source of the problem.
    – Dan
    Oct 27 '15 at 7:48
  • @Dan : I am glad that your problem got solved - enjoy ubuntu experience ! :)
    – cl-netbox
    Oct 27 '15 at 8:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.