3

I installed xubuntu-desktop to give XFCE a try, and during that process it got stuck installing a few packages. It got stuck on setting up blueman, hddtemp, or lm-sensors. I eventually ended up skipping these packages as I didn't need the services they provide.

However, now if I ever try to run an apt-get upgrade, or install a new package, it tries to finish the installation of blueman every time. I am unable to install anything or upgrade my packages because of this.

Is there something I can do to get rid of these packages and stop it thinking that it needs to install them?

For what it's worth, I'm using another desktop environment now and want to remove xubuntu-desktop.

1
  • Usually best to let it do whatever it is doing (some large packages etc may take a while) as killing it genrally makes it more annoying later. BTW with xubuntu-desktop uses pretty much the same stuff as every other desktop so you probably only really need to worry about the xfce* packages.
    – Wilf
    Oct 26, 2015 at 9:40

2 Answers 2

4

These commands might fix your problem.

  1. sudo apt-get clean
  2. sudo apt-get install -f
  3. sudo dpkg --configure -a

if those commands fail

try to remove the broken packages.

blueman is Bluetooth Manager if you use blue tooth you will need to install blueman.

sudo apt-get remove --purge blueman hddtemp lm-sensors

Then try to run the command above again. after removing the packages.

If still no luck. provide the out put of sudo apt-get install -f, sudo apt-get dist-upgrade and sudo dpkg --configure -a if any.

4
  • I was able to 'remove --purge' blueman, but unfortunately for both hddtemp and lm-sensors it just hangs on 'Removing hddtemp' and 'Removing lm-sensors'. The result is any operations I try to do with installing, upgrading or 'sudo dpkg --configure -a' has the same result as before; it gets stuck 'setting up <package name>'.
    – user465116
    Oct 26, 2015 at 9:28
  • @Chris post the out put of the commands that I gave you. telling me that it hangs on Removing hddtemp and Removing lm-sensors tells me nothing.
    – Neil
    Oct 26, 2015 at 9:31
  • During the last comment and this one I restarted my machine, and for whatever reason the problem seems to have disappeared. Thanks for your help.
    – user465116
    Oct 26, 2015 at 9:48
  • @Chris Can confirm I was stuck on Setting up apt (1.2.27) many times in a row. After rebooting I could run dpkg --configure -a and apt finished configuring along with apt-utils. Now I can use sudo apt install again. YEAH! Aug 2, 2018 at 0:01
1

Open a terminal and run apt-get update and apt-get upgrade, let it finish or post what exactly is happening.

3
  • apt-get update succeeds as normal, apt-get upgrade hangs on 'Setting up hddtemp' (I have successfully removed blueman, but no luck with hddtemp and lm-sensors.)
    – user465116
    Oct 26, 2015 at 9:31
  • can you try to force the removal dpkg -P --force-all hddtemp ? and a stupid question, do you have enough space in /tmp ?
    – mestia
    Oct 26, 2015 at 9:42
  • I since restarted the machine and it seems to have somehow fixed the issue. Thanks for your help.
    – user465116
    Oct 26, 2015 at 9:49

You must log in to answer this question.