9

I installed WICD and it works fine, but the tray icon doesn't show. I've tried with wicd-client but only a notification shows up.

root@prat-VGN-NR21M-S:~# wicd-client
Has notifications support True
rename failed
Loading...
Connecting to daemon...
Connected.
displaytray True
Done loading.

In addition, under Kubuntu session the tray icon shows normally.

Thanks in advance.

  • >>For Ubuntu 12.04 use ['All'] in desktop ➜ unity ➜ panel (delete all others) >> >>worked for me :) me2 thanks! bcm4321, bw43 driver. with off-the-dvd 12.04 32bit install, network-manager and iwlist were showing the available (visible) network list inconsistently, and rarely. – user195603 Sep 24 '13 at 5:28
9
  1. Install the dconf-toolsInstall dconf-tools package and then open dconf-editor:

    enter image description here

  2. Navigate to desktop ➜ unity ➜ panel and add Wicd to systray-whitelist :

    enter image description here

  3. Log out and then back in. You should see the wicd icon the panel:

    enter image description here

  • 1
    every day we have these questions. unity needs redesign, hiding stuff is really nonsense for me. – c0de Jan 2 '12 at 22:31
  • 3
    This answer did not work on 11.10 Unity. dconf changes are discarded and the default is used after logoff/logon – keepitsimpleengineer Jan 6 '12 at 0:42
  • Anyone know if 12.04 is different? – Tarrasch Aug 22 '12 at 21:39
  • 1
    This method does not seem to work on 13.10. How unfortunate. It could be that there is something to it in the startup applications. For example changing the WCID entry to wcid-gtk to wcid-client --no-tray. :/ – Zlatty Feb 9 '14 at 23:26
  • 2
    This method does not work for Ubuntu 14.04 and upwards. Ubuntu removed the whitelist option from dconf. – Babbzzz May 15 '15 at 7:28
1

For Ubuntu 12.04 use ['All'] in desktop ➜ unity ➜ panel (delete all others)

worked for me :)

  • are your instructions to be performed in dconf-tools package, you're not very clear... – Abraham Murciano Benzadon May 11 '17 at 14:38
1

For Ubuntu 14.10, following the instructions here will get the WICD icon in the top panel.

0

For Ubuntu 11.10 , this article gives a solution for 11.10. Cant try it now, though.

wget http://www.pc-freak.net/files/add-wicd-to-whitelist.sh
sh add-wicd-to-whitelist.sh

And the code of the script

#!/bin/bash

TEMPFILE="/tmp/whitelist.temp"

rm -f $TEMPFILE
gsettings get com.canonical.Unity.Panel systray-whitelist | head -c -2 > $TEMPFILE
echo -n ", 'Wicd']" >> $TEMPFILE
gsettings set com.canonical.Unity.Panel systray-whitelist "`cat $TEMPFILE`"
rm -f $TEMPFILE

A restart (login/out) is required, too.

The script should do the same thing that the proposed solution above does...

  • 1
    The script indeed does the same thing, it adds Wicd to the white-list. But there is still no 'Wicd; icon in the system notification area. – keepitsimpleengineer Jan 16 '12 at 18:41

protected by Community Jan 5 '14 at 10:34

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.