0

LastPass Sesame (Ubuntu/Debian) Sesame was working normally before the new Ubuntu update 15.10. However, now I get this error when I try to execute the command.

John@John's-PC:/media/crypt1$ ./sesame_x64 ./sesame_x64: error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No such file or directory

So, I did a clean install following the instruction below.

  1. Right-click the download button and choose 'Save Link As'
  2. Extract the tar.bz2 file
  3. Run 'sudo apt-get install ca-certificates libssl0.9.8' to update necessary packages

When I run the sudo apt-get install ca-certificates libssl0.9.8, I get this message:Reading package lists... Done Building dependency tree
Reading state information... Done Package libssl0.9.8 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source

N: Ignoring file 'getdeb.list.bck' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension N: Ignoring file 'getdeb.list.bck' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension E: Package 'libssl0.9.8' has no installation candidate Anyone know how to fix this problem? Thanks so much!

1

libssl0.9.8 is only available in previous repository versions of Ubuntu, namely:

  • precise (12.04LTS) (libs): SSL shared libraries [universe] 0.9.8o-7ubuntu3.2 [security]: amd64 i386
  • precise-updates (libs): SSL shared libraries [universe] 0.9.8o-7ubuntu3.2: amd64 i386
  • trusty (14.04LTS) (libs): SSL shared libraries [universe] 0.9.8o-7ubuntu3.2.14.04.1 [security]: amd64 i386
  • trusty-updates (libs): SSL shared libraries [universe] 0.9.8o-7ubuntu3.2.14.04.1: amd64 i386
  • vivid (libs): SSL shared libraries [universe] 0.9.8o-7ubuntu4: amd64 i386

If you have Ubuntu 15.10+ (wily+), libssl0.9.8 is obsoleted by libssl1.0.0:

  • wily (libs): Secure Sockets Layer toolkit - shared libraries 1.0.2d-0ubuntu1: amd64 i386

In short, this means that Sesame has to update to use the newest version of libssl, or you have to revert to an older version of libssl.

More information on this here:

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.