So I took the plunge and did a clean install of ubuntu 11.10 rather than an upgrade, safe in the knowledge that my home dir would be safe on its own partition like it has always been for years.

After the install though, i had many issues - sound was broken, the network manager applet would not detect any devices, i couldn't shutdown or logout.

The .xsession-errors file is full of lines like:

** (gnome-settings-daemon:1591): WARNING **: Failed to get session for pid: GDBus.Error:org.freedesktop.ConsoleKit.Manager.GeneralError: Unable to lookup session information for process '1591'

(pastebin link: http://pastebin.com/download.php?i=7GMQCzBn)

Overall this seems to suggest there are some old permissions/configuration causing serious problems. The issue doesn't appear with the guest session, or a fresh account (which i had to create using the guest session as i couldn't unlock anything with my main account).

I've tried backing up things like .gconf and deleting to see if that would fix it, but overall i'm stumped.

Has anyone else had this issue with an upgrade/install with an old home dir? Can anyone offer some pointers?


this now seems to be some issue related to consolekit.

if i run ck-list-sessions on a new user it prints out a bunch of stuff about the session, but not on my old user. Still no idea why though :/


Found the issue!

It seems that it was taking took long for console kit to load, which in turn broke permissions for everything else. I had an .ecryptfs folder that seemed to be the reason it took too long to load, and deleting that fixed everything else.

| improve this answer | |
  • I solved the problem following your advice. I think this should be reported as a bug. – Damian Nadales Oct 31 '11 at 10:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.