2

A project i'm trying to compile needs mingw32. atp-get install gives me "Unable to locate package mingw32" doing a apt cache search yields many options and I need help choosing one that will work or eliminating this error.

System info: 4.2.0-16-generic #19-Ubuntu SMP Thu Oct 8 15:35:06 UTC 2015

Any ideas?

7

This package is in universe repository of Ubuntu . so make sure you have enable universe in /etc/apt/sources.list use command :

sudo apt-get install mingw32

it will install packages mingw32 mingw32-binutils mingw32-runtime automatically

and

sudo apt-cache search mingw32

mingw32 - Minimalist GNU win32 (cross) compiler
mingw32-binutils - Minimalist GNU win32 (cross) binutils
mingw32-runtime - Minimalist GNU win32 (cross) runtime

no need to select one. these packages are dependency of mingw32

Note : currently these package available in trusty , utopic and earlier version of Ubuntu if you are using latest Ubuntu version then check Ubuntu package search that package available or not . if not then either download package and install manually or download source and compile it.
EDIT: you can try this :

for 32bit system:

wget http://archive.ubuntu.com/ubuntu/pool/universe/m/mingw32/mingw32_4.2.1.dfsg-2ubuntu1_i386.deb
wget http://archive.ubuntu.com/ubuntu/pool/universe/m/mingw32-binutils/mingw32-binutils_2.20-0.2ubuntu1_i386.deb
wget http://archive.ubuntu.com/ubuntu/pool/universe/m/mingw32-runtime/mingw32-runtime_3.15.2-0ubuntu1_all.deb

for 64bit system

wget http://archive.ubuntu.com/ubuntu/pool/universe/m/mingw32/mingw32_4.2.1.dfsg-2ubuntu1_amd64.deb
wget http://archive.ubuntu.com/ubuntu/pool/universe/m/mingw32-binutils/mingw32-binutils_2.20-0.2ubuntu1_amd64.deb
wget http://archive.ubuntu.com/ubuntu/pool/universe/m/mingw32-runtime/mingw32-runtime_3.15.2-0ubuntu1_all.deb

install these packages using command :

sudo dpkg -i *.deb

if it shows dependencies then use command :

sudo apt-get install -f

and again install

 sudo dpkg -i *.deb
  • I'm running wily & yes universe is enabled – injijagwalaafq Oct 26 '15 at 7:18
  • try updated answer . – pl_rock Oct 26 '15 at 15:17
  • changing the OS to ubuntu-14.04-lamp_64bit seems to have solved all my problems. Thanks! – injijagwalaafq Oct 26 '15 at 18:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.