About a week ago, I bought a new laptop (Asus Zenbook UX303LB). I immediately threw out the included Windows installation and installed Ubuntu 15.04 (later upgraded to 15.10, and also reinstalled at some) to replace it. The system has been working just fine.

A couple days ago I noticed, that I didn't have proprietary Nvidia drivers installed. I installed them, and saw major tearing artifacts on the screen. I can switch the prime profile to Intel, but then the Nvidia graphics card can't be utilized at all.

I have tried installing Bumblebee to fix the afforementioned issues (and improve battery life when not using the NVidia card). The guide I followed can be found here. No matter what I tried (stuff mentioned in the comments of that question, and methods used in other articles), I always got the "The system is running in low-graphics mode" screen, and could only use the text-based ttys. I have then had to recover from a backup.

I have only tried installing Bumblebee alongside the nvidia-352-updates drivers so far. Are they problematic? Another issue I percieved, was that the /etc/X11/xorg.conf file was always overwritten to a format which seemed illogical (The only display in use was nvidia, but it was not defined and the intel display was set to be inactive).

So, is there any way I could install Bumblebee (or something similar, as long as it atleast takes care of the tearing) properly?

More info:

After attempting to install bumblebee using philsegeler's method (and using other methods as well), trying to proceed in the "The system is running in low-graphics mode" dialog and choosing "Try running with default graphical mode" results in this:

[...] [drm:intel_pipe_config_compare [i915]] *ERROR* mismatch in base.adjusted_mode.crtc_clock (expected 138780, found 92519)
[...] [drm:intel_pipe_config_compare [i915]] *ERROR* mismatch in base.adjusted_mode.crtc_clock (expected 138780, found 92519)
[...] [drm:intel_pipe_config_compare [i915]] *ERROR* mismatch in base.adjusted_mode.crtc_clock (expected 138780, found 92519)
[...] [drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!

As I described earlier in the post, this is what the xorg.conf now looks like:

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "PCI:0@0:2:0"
    Option "AccelMethod" "None"

Section "Screen"
    Identifier "intel"
    Device "intel"
  1. Uninstall nvidia-prime:

    sudo apt-get remove --purge nvidia-prime
  2. Install bumblebee and the nvidia driver

    sudo apt-get install bumblebee bumblebee-nvidia nvidia-352 nvidia-352-uvm nvidia-settings primus
  3. Do sudo gedit /etc/modules and add

  4. Do sudo gedit /etc/modprobe.d/bumblebee.conf and make sure the line

    blacklist nvidia-352
    # is there, if not add it. This is most probably what caused you to boot into low-graphics mode
  5. Do sudo gedit /etc/bumblebee/bumblebee.conf

    • line 22: >Driver=nvidia

    • line 55: >KernelDriver=nvidia-352

    • line 58: >LibraryPath=/usr/lib/nvidia-352:/usr/lib32/nvidia-352

    • line 61: >XorgModulePath=/usr/lib/nvidia-352/xorg,/usr/lib/xorg/modules

  6. reboot.


  1. http://rajat-osgyan.blogspot.gr/2015/05/how-to-install-latest-nvidia-driver-in.html

It is approved by many (and me)to work, though the difference is that I don't use ppa:xorg-edgers (since it is unstable) I recommend you do that instead.


  • Use primusrun %command% in steam launch options
  • and primusrun programname for everything else you want to run on nvidia. This should eliminate tearing for you and make vsync work again!

Hardware: Samsung NP550P5C S02
CPU: Intel i5-3210M
GPU: Nvidia GT 650M

  • Thanks for your reply! I'm afraid I've already attempted the installation following that guide as well, although I could try it again. – ollpu Oct 25 '15 at 17:21
  • you followed rajat?? then really make sure you dont have ppa:xorg-egders in your software sources and follow every step carefully! It should work that way! Try it again! – philsegeler Oct 25 '15 at 17:34
  • In addition you may probably have to sudo systemctl bumblebeed, i have 14.04 so cannot comment on that! – philsegeler Oct 25 '15 at 17:36
  • I will try it again when I have some spare time. – ollpu Oct 25 '15 at 17:55
  • I'm still getting the "The system is running in low-graphics mode" with or without the edgers ppa. By the way, I couldn't find the package "nvidia-352-uvm" again with or without the edgers ppa. Is it crucial? I figured it is now included in nvidia-352. – ollpu Oct 28 '15 at 15:51

I had similar issues. I didn't notice that much screen tearing with Prime, but there was a problem which required me to reboot every time I wanted to switch GPU. However, after installing Bumblebee I would always get a black terminal at log-in, no matter which guides or posts I followed. I spent two weekends installing and unintalling various combinations of drivers and finally got it to work by installing both Prime and Bumblebee.

I'm using the nvidia-355 drivers from the graphics-drivers PPA:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update

First, I completely uninstalled my graphics drivers and reinstalled nouveau (I got these instructions from various parts on the internet and eventually put them together in a script because I was reinstalling stuff all the time):

# Remove everything to do with the Nvidia proprietary drivers.
sudo apt-get remove -y --purge nvidia* bumbleblee*

# Start from scratch.
sudo apt-get remove -y --purge xserver-xorg-video-nouveau

# Reinstall all the things!
sudo apt-get install -y nvidia-common
sudo apt-get install -y xserver-xorg-video-nouveau
sudo apt-get install -y --reinstall xserver-xorg-core

# Reconfigure the X server.
sudo dpkg-reconfigure xserver-xorg

# Remove leftover xorg.conf files
sudo rm /etc/X11/xorg.conf

Then, I followed these steps from this thread:

  1. Install nvidia-355, nvidia-prime and nvidia settings.

    sudo apt-get install nvidia-355 nvidia-prime nvidia-settings
  2. Select intel driver in nvidia panel and logout (or in my case: reboot).

    sudo prime-select intel
  3. Install bumblebee only (not bumblebee-nvidia) and edit /etc/bumblebee/bumblebee.conf as per the instructions from the rajat guide.

    line 22 -> Driver=nvidia
    replace nvidia-current with nvidia-355 everywhere in the file (line 55, 58, 61)
  4. Edit: /etc/bumblebee/xorg.conf.nvidia and uncomment BusID "PCI:01:00:0".

I have no idea why this would work while the other solutions wouldn't, but there you have it. I hope it works as well for you as it did for me.

For reference, here's my own post about the topic.

Edit -- One more thing. After all of this, I would get start-up issues caused by nouveau. I'd only be able to boot into the system by pressing e at the Grub screen and adding "nouveau.nomodeset=0" to the line that starts with "linux". I tried various solutions to make this change permanent, but in the end the only thing that worked was reinstalling nvidia-355, nvidia-settings and nvidia-prime again.


Replace bumblebee with nvidia-prime to switch between integrated and dedicated graphics.

Reinstall the NVIDIA drivers, but first uninstall all NVIDIA software and remove the bumblebee.

Open a terminal and execute:

sudo apt-get purge nvidia* bumblebee  
sudo reboot  

Install the stable NVIDIA drivers from the Ubuntu repositories (valid for Ubuntu 15.10 only ) :

sudo apt-get update
sudo apt-get install nvidia-352 nvidia-prime
sudo reboot
  • I currently do have nvidia-prime installed and working. The main issue, as described in my question, is that when using the nvidia-profile, I experience major tearing artifacts. Bumblebee would also automatically switch the profile, without me having to manually flip between the two and have to log out and back in, as prime requires. – ollpu Oct 25 '15 at 14:41
  • @ollpu : You can only use bumblebee OR nvidia-prime ... so remove bumblebee and use ONLY nvidia-prime (recommended switching tool). :) – cl-netbox Oct 25 '15 at 14:47
  • I don't have bumblebee installed in any manner (completely clean system + nvidia drivers, which come with nvidia-prime), but I still experience tearing. This is a known issue with nvidia-prime. – ollpu Oct 25 '15 at 17:24

on my Asus UL30VT, with new Ubuntu / Mint, there is an init script called gpu-manager, which has no idea how to deal with hybrid graphics. It routinely tries to force nVidia on me, so I have found I need to disable it to succeed with Bumblebee. To do that, I simply commented out all the lines in /etc/init/gpu-manager.conf, so it looks like this:

#start on (starting lightdm
#          or starting mdm
#          or starting kdm
#          or starting xdm
#          or starting lxdm)
#exec gpu-manager --log /var/log/gpu-manager.log

I also had to:

sudo rm /etc/init.d/xorg.conf

Then a reboot gave me a graphical login.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.