How do I disable all effects in Ubuntu 15.10?

I already called this on the console:

gsettings set org.gnome.desktop.interface enable-animations false

But it doesn't seem to have a great effect, When I open the Ubuntu dash, it still gently fades in.

How can I disable all effects, so I minimize the usage for my graphic card?

I know, there are more lightweight solutions like Lubuntu or Xubuntu, but I would like to stay on plain Ubuntu.

up vote 73 down vote accepted

There are some you can disable using the unity-tweak-tool.

Install:

sudo apt-get update
sudo apt-get install unity-tweak-tool

Run:

unity-tweak-tool &

Click on Launcher (in the Unity section) and in the Launcher tab:

  • set Auto-hide to off
  • set Urgent animation to No animation
  • set Launch animation to No animation
  • set Icon backgrounds to No colouring.

In the Search tab:

  • set Background blur to off.

Click on the Overview button at the top to go back to the main menu.

Click on General (in the Window Manager section). In the General tab:

  • set Desktop magnification to off
  • set Texture quality to Fast
  • set Window Animations to off.

Additionally, you can turn off more animations in ccsm.

Install:

sudo apt-get install compizconfig-settings-manager

Run:

ccsm &

In the effects category, untick all of the boxes.

In the accessibility tab, untick all of the boxes.

There are probably more you could disable in compiz as well.

  • 4
    compizconfig-settings-manager is quite dangerous, I ended up with a desktop without any window decorations. I could only repair this by disabling "Composite" an re-enable "Ubuntu Unity Plugin" – rubo77 Oct 25 '15 at 8:36
  • @rubo77 well of course you need the Ubuntu Unity Plugin as unity is only a compiz plugin and nothing more silly. There is nothing dangerous it's all completely fixable. – mchid Oct 25 '15 at 8:37
  • @rubo77 also, you should be able to have composite enabled but change slow animations to disabled – mchid Oct 25 '15 at 8:39
  • It seems like the setting "enable low graphics mode" in the Unity Plugin settings seems to solve a slow unity dash – rubo77 Oct 25 '15 at 9:02
  • 1
    I Understand, but the dash stays animated (on <Super> key), no matter which settings I try. so the low graphics mode seems the best we can get. – rubo77 Oct 25 '15 at 9:11

My advice is to install the compiz configuration manager and disable them, be warned that you have a possibility of breaking the system, it def works though (not sure if it works on 15.10) but is generally found in the Ubuntu software center. However give this a try for the temrinal.

sudo apt-get install compiz compizconfig-settings-manager

Open up a terminal and type sudo ccsm, click effects then uncheck animations and fading windows.

You can muck around with a lot of other things in there as well provided you know what you are doing

  • 3
    What in Your answer is new? I think that is already said in the accepted answer – rubo77 Apr 5 '17 at 14:15
  • Sorry was a bit careless and tired and didnt read the 2nd alternative mentioned, it happens – Dylan Coulbeck Apr 7 '17 at 3:36

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.