Been trying over and over, but nothing happens. Tried reinstalling Steam along with Ubuntu but that didn't do anything either. Tried other forums with helpful tips but no good. I'm running out of ideas and I don't know what else I can do. Can someone please help me before I start pulling my hair out? I'm going mad.

  • Where are you installing Steam from? Repositories or downloading it? And did it ever launch (e.g.: when you were on an earlier version)? – user364819 Oct 26 '15 at 18:45
  • I think they fixed it, beacuse just recntly, sudo apt-get install steam-launcher started working on all 3 of my computers – Gman Smith May 5 '16 at 23:15
  • I also had this problem, I was surprised to see this it because i had no problems on my laptop with exactly the same OS files (installed Ubuntu from the same USB stick). @Daniel's solution below worked for me though – sunyata Jan 18 at 19:48

Based on this question, execute the following commands:

mv ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1{,.disable}
mv ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6{,.disable}

The idea is that Steam uses it's own dynamic libraries but Ubuntu comes with some new ones, or something like that, any way it works!

NOTE: If you're just installing Steam for the first time, you will need to run the commands a second time after the initial update. This will take a lonnnnnnng time!

UPDATE:

If you use 16.10, the guys from Ubuntu provided a modified installer that takes care of this issues. I would recommend to install Steam from the Ubuntu repositories

  • 3
    Confirm, it works perfectly! Thank you. – landas Oct 26 '15 at 21:50
  • I had to modify these commands as the files are in ~/.steam, not ~/.local/share/Steam. – psusi Jan 9 '16 at 19:36
  • Solved for me on Linux Mint 17.3 – Ben Mordecai Jun 19 '16 at 22:49
  • 1
    This barrier must be solved in the installation process. This make many user give up using Linux. – Kin Aug 19 '16 at 15:07
  • Great that i do not sleep so i can enjoy the magic of non-Windows – Weapon X Sep 10 '16 at 23:53

Based on Daniel's answer (i don't have the rep to comment!), on a vanilla ubuntu-gnome 15.10 where i've done an 'apt-get install steam' I had to run these modified commands:

mv ~/.steam/steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6{,.disable}
mv ~/.steam/steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1{,.disable}

So just changing out the .local/share which wasn't present on my system

  • You may want to just propose an edit if you believe it has changed. – TheWanderer Mar 17 '16 at 21:07

protected by Community Nov 26 '15 at 15:12

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.