26

The situation where I am stuck:

screenshot

The issue is that I am trying to install Ubuntu 15.10 as my primary OS.

I had windows 10 and tried to use both OS in dual boot but got stuck at some point. So my easiest option was to take backup and entirely delete the previous OS (Win 10 in this case) and install Ubuntu 15.10. All went great until the fatal error popped up.

Bootloader install failed .. and then it askes me "how would you like to proceed?" Giving me three options:

  1. choose a different device to install the boot loader .. between /dev/sda ATA WDC WD7500BPVT-2 (750.2 GB) and /dev/sda1 and then not continuing when I click on OK.

  2. continue without a boot loader .. saying that I will need to manually install a boot loader in order to start Ubuntu. Then again not proceeding when I click on OK

  3. cancel the installation.. Saying that this may leave my computer unable to boot. Then again not proceeding as I click on OK.

What should I do in this case?

18
  • Install it on /dev/sda
    – Raphael
    Oct 25, 2015 at 7:10
  • 1
    @Raphael i am trying but no matter how many times i try to click on ok it doesn't react in anyway !!
    – user464758
    Oct 25, 2015 at 7:23
  • 1
    Because if it can be then install it and then reinstall grub following this tutorial - howtoubuntu.org/…
    – Raphael
    Oct 25, 2015 at 7:29
  • 1
    @Raphael it doesn't allow me to go on .. no matter what options i choose .. when i click ok it doesn't react in anyway !
    – user464758
    Oct 25, 2015 at 7:31
  • 1
    It's just absolutely amazing to me that 4-1/2 years later, when trying to install Ubuntu 20.04 and I get this same error, the OK button still doesn't work. It simply won't let me choose any of the three options.
    – Tobias J
    Apr 26, 2020 at 23:10

13 Answers 13

9

I faced a similar problem (see screenshot) - Installation with Internet connection solved it.

Imgur

5
  • 1
    I'm installing Xubuntu into a VM (backed by physical disk.. long story) and this solved it for me as well. I set the network adapter as disconnected and reset the VM, and then the installation succeeded.
    – Ricket
    Nov 10, 2016 at 2:34
  • 3
    Please, can you clarify what you mean by "Installation with Internet connection solved it"?. I was installing Ubuntu with internet connection enabled and I got the "Bootloader install failed" dialog. Did you choose any option from the dialog or did you start the installation process again? Thank you. Sep 10, 2017 at 10:21
  • This answer really is useless. Could you please specify the steps you took.
    – gideon
    Mar 16, 2018 at 16:13
  • It's not useless, it worked for me. What I did and what worked for me is that I chose Try Ubuntu, once I had the desktop up I had connected to the Wifi network, then I started the setup and I made sure I have enabled downloading updates during install. Without this I was hit with the same error. May 15, 2018 at 21:18
  • In my case it appeared during installing Lubuntu 18.04, I had an internet connection. Dec 15, 2019 at 18:43
5

I have faced the same issue. In my case the problem was that I was trying to install Ubuntu in no-UEFI mode, alongside WIN10 which is installed in EUFI mode (most recent BIOS replacing MBR).

So my solution was:

  1. create a new bootable USB with my Ubuntu distro (15.10) using
    Rufus utility, supporting EUFI partition scheme - meaning that it will allow you to install Windows or Linux OS in full EFI mode
  2. entered the BIOS with following settings:

    • Secure boot [disabled]
    • Fast Boot [disabled]
    • set CSM compatibility back as [disabled] - some posts suggest to enable but I think it is not needed when installing in full EFI mode
  3. In BIOS look for override boot options (in my case under Save & Exit tab > Override boot) there I could see my USB key as "UEFI: SanDisk...". I selected it and this started the Ubuntu installer and everything went smoothly.

2
  • Encountered same problem like user464758 described in his question with the difference that i wanted to install Mint alongside Win7. Your solution worked for me.
    – sepplhans
    Jun 30, 2017 at 19:56
  • 1
    This solution is excellent for anyone trying to install outside of the UEFI. Worked for me. Aug 3, 2021 at 2:18
1

I had the same problem - the boot install failure and dialogue that wouldn't close. I had this when installing from a live-usb session. Restarting from the boot menu's install option worked for me.

1

I had exactly this same problem. But specifically, I was installing to an internal SSD with two partitions: one for all of linux (root or "/") and the other for "AllMyData". (I do have a hdd, but use it as a backup for my network)

When I first tried to install Ubuntu I used the option to reinstall Xubuntu (over the existing 15.10 - because I'm having some Python issues), but it resulted in the same error at described in the question. I then tried installing it beside the existing OS - but that also resulted in an error. I then tried to replace the existing OS -- same error.

I then found this question (that described exactly my problem), and I tried all of the suggestions mention: 1) I did a checksum and it was not a corrupted iso. 2) There is no reason why the sdb (SSD) should not work, as I've used it before and checked that it is working properly. 3) The other issue re: Install with an Internet Connection -- well, I had an internet connection. None of the suggestions (answers) worked for me.

The only option that worked for me was, when asked for the kind of installation, to select "Other Installation". But be warned you need to know how to work with partitions, or take some time to read up on using Gparted and setting up Linux. (I can add links if it is needed, but a simple search on AskUbuntu should find info regarding this.) The bootloader and all of Ubuntu loaded without any errors -- as per my setup in the "Other Installation" -- for me, I installed grub on sdb (not sdb1 or sdbx). I would suggest that this is an Ubuntu bug, and found some reference to problems installing to USB, but at this point in time I'm fine with using the option that worked for me.

1
  • Yes, please do add the links!
    – Andrew K
    Apr 29, 2016 at 20:38
1

I had this same problem trying a fresh install of Ubuntu Mate 17.10 on a new HDD in a desktop PC. I tried many of the answers in this thread and from here. Custom partition setup works fine but if you want to use guided partitioning, this answer from SuperUser.com solved the problem for me. Quote:

I finally got rid of the error. And to be honest, it's stupid.

The problem actually was, that the /boot partition wasn't created, even though it was shown in the UI. It's still possible to get everything running with the guided partitioning, but when you're asked to Write the changes to the disk?, you need to go <Back> to see a detailed list of all partitions. When clicking <Next>, the installation will finally recognise and partition everything correctly and as expected.

0

Install it on /dev/sda -- Raphael

@Raphael i am trying but no matter how many times i try to click on ok it doesn't react in anyway !!

There probably is nothing to click because it is a TUI interface (1, 2). Use the arrow keys, space and return/enter.

1
  • 4
    The button visibly toggles, but still doesn't do anything. Aug 28, 2016 at 23:44
0

Seems like something is corrupted.

If the OK button is not getting pressed at all, then it just might be that you have a broken ISO.

Try redownloading. As a side note, I would wipe the MBR. (note that this deletes your partition tables and would render your PC unbootable until you install a new OS.)

Note that if you proceed without installing grub(bootloader), you cannot boot into your ubuntu installation. You will have to configure grub later on.

0
0

I found the problem, the installer is looking for a decompression command that some systems SSE does not have which prevents the boot loader archive from being found and opened when the USB boot drive is made in ISO mode.

My solution is to get Rufus 2.8.886 bootable usb maker (it's free) and run through the usual configure, however when you select your linux ISO file, choose in Rufus the "DD" mode which in layman's terms means to simulate a HDD so that the computer and installer don't get confused but partitions and file types. Don't worry if you can't see the prepared DD type USB drive in windows file explorer, you will only see a couple .EFI files. Just boot off the USB drive as usual and it will properly install the bootloader.

0

I ran into this same problem when installing Lubuntu 16 on a rather old Laptop (HP Compaq CQ85): Exactly this crash after 50% progress when trying to install grub. I only wanted Linux to run, no Windows in parallel. My assumption is that the installer starts from USB in non-EFI mode but then tries to install an EFI bootsystem on the harddrive. Forcing both, BIOS AND installer NOT to use EFI worked for me:

1.) I created the USB installer with unetbootin (doesn't matter, actually Rufus does the same), but it was NOT the EFI style of boot media.

2.) I had to allow legacy boot support in my BIOS settings and turn EFI off.

3.) On the USB drive I edit the file /boot/grub/grub.cfg by adding the word 'noefi' to the existing kernel parameters, like this: (careful with copy and paste from the next tiny window! End of line invisble!)

    ...[section 'install ubuntu']
    linux   /casper/vmlinuz.efi  file=/cdrom/preseed/lubuntu.seed boot=casper noefi only-ubiquity quiet splash ---

This will force the installer to create the old legacy bootloader and not an EFI boot partition.

0

This type of error in most cases is nothing to do with software. The installation becomes confused when the drives are not configured correctly within the BIOS. First check the BIOS to see if the SATA drives are listed in the correct order. If not, it will require the computer to be opened up and the cable connections to be inserted in the correct motherboard locations. Given the motherboard type, the correct plugins may not always be obvious so re-check the BIOS for drive order. A correct setup would be as follows: Example SSD (to be boot drive), Sata1, TB (data drive), Sata2 and DVD Sata3. When this is completed and all drives are in the correct order, you should have no problem installing your OS.

0

Even I faced the same error while installing the linux for 64 bit in Oracle VM Virtual Box.
Solution that worked for me :
First Create the virtual Device and before starting the ubuntu system go to
Settings of Oracle VM ->System->Processor->Make Processor(s) to 2 CPUs
and click OK then start the ubuntu system.
Also I did't checked the LVM Partition Option Try it If it works for you.

0

I had the same problem installing Mate 20.04 LTS on a HP Z800, after successfully installing it on NVME Boot drives (Samsung 970 EVO+ in PCIe adapter) on two HP Z440s.

Somewhere I saw a post suggesting that the bug happens when there's more than a single drive and the first one "seen" by the ubuntu installer isn't the one where you want the loader. This Z800 has a LSI 9260-8i Megaraid PCIe card supporting 5 HDDs configured as two virtual drives (usually it runs Win 10) and they come up ahead of anything plugged into the on-board SATA ports. I unplugged the drives connected to the 9261 so that the intended boot drive was the only game in town. Install was then fine. Plugged the drives back in, and they're fine too. Thus I can endorse this solution.

0

You also encounter this issue when attempting to install Ubuntu 20.04 / Mint 20 on a LUKS encrypted volume or LVM on LUKS if you've created this encrypted volume manually before starting the installation and not using the wizard.

The solution is to enabled encryption support in GRUB i.e. create a file /target/etc/default/grub.d/local.cfg with the contents GRUB_ENABLE_CRYPTODISK=y before the installer attempts to install the bootloader.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .