5

I just upgraded to 15.10, and everything went smoothly. One of the first things I did was install gnome-shell, and switch from lightdm to gdm. However, when I restarted, after an initial purple Ubuntu load screen, I got a grey/black screen that never went away. I switched back to lightdm and everything worked fine again. Is this a problem with gdm in 15.10, or is there something I am not doing/doing wrong? Thank you!

Update:

I have been following this bug report: bugs.launchpad.net/ubuntu/+source/gdm/+bug/1500673 originally linked below by @ulkeshkosh, and there is some new activity there including a suggested fix that worked for one user. I tried this fix, and it didn't work for me, nor did it work for the other commenters, but it might work for someone else visiting this post.

However, a word of warning: one commenter mentions this line in /etc/gdm/custom.conf:

[daemon] # Uncomment the line below to force the login screen to use Xorg #WaylandEnable = false

the commenter does not suggest modifying this line in any way, but being an inexperienced and curious Linux user, I decided to see what happens when I uncommented it, and the results were quite a pain to recover from, so I would suggest that you not experiment in this way.

  • sometimes the fix for a gdm problem is to switch to lightdm for some reason – mchid Oct 25 '15 at 5:53
  • 1
    @mchid yes, this does fix the problem in my case, but in the past has caused other problems for me using gnome-shell, like the lock screen and screen saver not working (that is, using lightdm with gnome-shell doesn't always go smoothly) – elethan Oct 25 '15 at 13:40
  • 1
    I have gdm, lightdm related problems on two computers I have upgraded from 15.04 to 15.10. I was not able to get the graphical logon until I changed the gdm. I have lightdm now set as default on both and it works. The command is "sudo dpkg-reconfigure gdm". – nobody Oct 26 '15 at 10:40
  • 1
12

I finally got gdm to work properly. Initially I had just installed gnome-shell, which allowed me to use the GNOME desktop environment, but didn't allow me to use gdm with it, as described above, which causes certain other problems, like being unable to lock for example, and other issues mentioned in the comments to the question.

The solution was to install ubuntu-gnome-desktop:

sudo apt-get install ubuntu-gnome-desktop

After that, I changed my display manager back to gdm with:

sudo dpkg-reconfigure gdm

and after restarting I was greeted with the appropriate login screen, and everything has worked smoothly so far.

I am assuming this fix worked because of either some extra dependencies that were needed, or some extra tweaks that were made to configuration files when installing that package. I don't have quite enough experience with LInux yet to understand why this worked, but it did, and hopefully it will too for others that have had this problem.

Update:

I cannot confirm whether this works or not because I have not tried it, but user @detly suggests in the comments below that 17.04 users should use gdm3 instead of gdm. Just wanted to highlight this just in case it is useful for users of later versions of Ubuntu.

  • 1
    Similar issue. New install of 15.04 working with gdm and nvidia drivers. Upgrade to 15.10. Could only access consoles on reboot. Setting wayland use to false to force Xorg did not work. Following this solution and a reboot all fine. – user74146 Nov 6 '15 at 0:02
  • I did this and it messed up my complete system. My desktop is non-responsive (No background image, no left-click). How can I make this undone?? removing ubuntu-gnome-desktop did not change anything – weelux Dec 28 '15 at 13:49
  • @user250045, If you were using GNOME, then removing ubuntu-gnome-dsektop will probably make things worse. However, the issues you are experiencing (left-clicking?) don't sound to me like they are related to changing desktop managers. You could try changing back to lightdm if you were using that before with sudo dpkg-reconfigure lightdm, but not sure it will work, because I don't know the details of your problem. I would suggest posting a new question describing what your original problem was, what you tried to solve it, and what happened afterwards in detail. Hope you get things working! – elethan Dec 28 '15 at 15:01
  • I meant right click. I tried both, lightdm and gdm. No difference besides the login screen. – weelux Dec 28 '15 at 19:22
  • 1
    IT WORKED. Note for 17.04 users: it's gdm3 not gdm. – detly Apr 20 '17 at 12:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.