13

I just upgraded to Ubuntu 11.10 and I was wondering if it's possible to not list all the current users and instead require the user to type in their username? My company's IT policies require that users not be listed on login screens.

In Ubuntu 11.04, I was able to do this with the following commands...

$ sudo -u gdm gconftool-2 --type boolean --set /apps/gdm/simple-greeter/disable_user_list true
17

You can do this by editing /etc/lightdm/lightdm.conf The default contents are just:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu

And you can just add:

greeter-hide-users=true

To that. For the full list of options, see /usr/share/doc/lightdm/lightdm.conf (or look at this post about lightdm conf).

3

Answers suggesting you edit the conf file are wrong.

From the Ubuntu wiki:

LighDM configuration is governed by the /etc/lightdm/lightdm.conf file, however it's not suppose to be directly edited, instead use:

lightdm-set-defaults

I found the file in /usr/lib/lightdm/lightdm-set-defaults.

You would issue the following on the command line:

sudo /usr/lib/lightdm/lightdm-set-defaults --hide-users true
  • 3
    While this answer was true at the time of posting, the program lightdm-set-defaults no longer exists. Editing conf files is now the correct method to update the settings. Linux is awesome. – Mercury00 Dec 15 '15 at 23:07
1

both the above answers didn't work for me (Ubuntu x64 15.04).. the Ubuntu wiki for LightDM works for me, so thought to post here for others who are looking for it although they can too follow the wiki..

source: What is LightDM?

as per Ubuntu wiki if we want to override the system configured default session (provided in /usr/share/lightdm/lightdm.conf.d/50-ubuntu.conf) we should make a file /etc/lightdm/lightdm.conf.d/50-myconfig.conf and define our stuffs there...

for example i want to disable listing user accounts, enable manual login at greeting or login screen and disable guest so wrote the following in /etc/lightdm/lightdm.conf.d/50-myconfig.conf

first type: sudo mkdir /etc/lightdm/lightdm.conf.d/ in terminal to create lightdm.conf.d folder in /etc/lightdm/

then: sudo nano /etc/lightdm/lightdm.conf.d/50-myconfig.conf

and put the following lines:

[SeatDefaults]
allow-guest=false
greeter-hide-users=true
greeter-show-manual-login=true

now save the file and restart or logout, this is how i get it working.. :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.