2

when I am starting evince or nautilus from shell I am receiving those error-messages. Does anyone know how to fix them?

I tried to reinstall both programs but the error continues.

test@test-desktop:~$ evince

(evince:2210): Gtk-CRITICAL **: gtk_widget_hide: assertion 'GTK_IS_WIDGET (widget)' failed

(evince:2210): Gtk-CRITICAL **: gtk_widget_hide: assertion 'GTK_IS_WIDGET (widget)' failed test@test-desktop:~$ nautilus

(nautilus:6299): Gtk-CRITICAL **: gtk_icon_theme_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed

(nautilus:6299): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(nautilus:6299): GLib-GObject-CRITICAL **: g_signal_connect_object: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

Thank you.

  • 2
    I have the exact same problems on Ubuntu 15.10. I believe I had them in 14.04 as well. I have tried googling the evince error everywhere and the most relevant thing I found was this: bugs.launchpad.net/ubuntu/+source/evince/+bug/1377546 Sadly there is no known fix for it yet. I believe it has something to do with libgtk. Although I have the lastest versions the ubuntu wily repo (gtk+ 3.16.7 and 2.24.28), it still doesn't work. Looking at gtk.org/download/linux.php, it looks like 2.24 is the latest 2.x version but there is a 3.18 version. I might try installing that. I'll rep – user478461 Dec 2 '15 at 23:21
  • 1
    I have exactly the same problems. Is there still no fix? – Enrico Maria De Angelis Apr 7 '16 at 6:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.