I'm having a couple of issues that I did not have in 11.04 or 10.10. The first issue involves connecting to my bluetooth headset. I am able to successfully pair and connect to my Samsung headset for the first time. But as soon as I turn off the headset and later try to reconnect, I'm not able to reconnect the headset. When I try to activate the connection from the settings dialog, the switch toggle back and forth automatically between on and off and never reconnects. I should mention that I had no issues with the 11.10 beta version using the same exact headset.

I have no issues connecting to my bluetooth mouse on the same laptop. However, when I disconnect the bluetooth mouse, the trackpad is not automatically re-enabled. I have to log out and log back in to re-enable the trackpad after disconnecting the bluetooth mouse.

I'm using 11.10 with all the latest patches.

  • After reviewing the 11.10 bug list, it looks like the trackpad issue may be related to my ThinkPad. Looks like the Ubuntu founder Mark Shuttleworth reported a bug on 11.10 with a ThinkPad trackpad not responding. Not sure if it's related to the bluetooth connection issue or not. – BubbaJ Oct 26 '11 at 22:45

Well, I found a workaround solution to the issue. I posted a similar question over on the BlueZ developer mail list and got several responses. It seems that there was a regression bug introduced somewhere in Linux Kernel 3.0 that was related to the Bluetooth Secure Simple Pairing (SSP) protocol used by Bluetooth 2.1 + EDR devices. The bug prevents reconnection of a device that was originally paired using SSP mode, that is without entering the pin code during pairing. Here is a link to the bug report: https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/931860.

Its not clear when the bug will be corrected in the Linux Kernel or whether it will get incorporated in the 3.0 and forward releases. If you are experiencing this same issue, there is a workaround that worked for me. The workaround involves disabling Simple Secure Pairing and letting the pairing default back to regular non-SSP mode. You can accomplish this by running the following command:

sudo hciconfig hci0 sspmode 0

You'll have to run this command again after each reboot in order keep it disabled to allow reconnections to happen. I hope this helps someone else as I've spent many frustrated hours trying to find a solution to fixing something that just used to work in prior releases.

| improve this answer | |
  • Is there any way to persistently set sspmode to 0 so I don't have to run that command every reboot? – Nathan Osman Oct 17 '14 at 23:44
  • @NathanOsman you could try adding the command to /etc/rc.local – MountainX Mar 13 '16 at 2:58
  • Thanks! I tried this command line on my 14.04 and I was able to finally connect my Akai portable speaker! – Cristiana Nicolae Sep 16 '18 at 18:48

blueman successfully working in ubuntu 10.04 LTS and other 10.04.3 s. Since ubuntu 10.10 released bluetooth derived on bluez. so after disconnecting any bluetooth device it will not be connected until computer restarts. these issues can be bypassed using ubuntu 10.04.3 LTS. It will be supported until 2013. and has no issues of any kind.

| improve this answer | |
  • I've been using the same bluetooth adapter and headset since 10.10. Did not have the same issue in previous releases. I could always re-establish the connection. It would not reconnect automatically, but I could always reconnect manually in versions before 11.10. – BubbaJ Nov 8 '11 at 14:42

I had exactly the same problem on two machines after upgrading to Ubuntu 11.10 (switch toggling back&forth, no 2nd connection possible).

I am using the "blueman applet" from the software-center and can use my headset again as in Ubuntu 11.04. Unfortunately the blueman dialogs are sometimes a little buggy (text disappearing), but you only need them once for pairing. Please make sure though, that you enable the blueman-indicator by adding 'blueman' to desktop->unity->panel->systray-whitelist in the dconf-editor. Otherwise, there will be no blueman-indicator which I find very handy...

| improve this answer | |
  • Thanks for responding. I will try installing blueman and report back. In the meantime, do you know if I need to uninstall the ubuntu bluetooth manager (gnome-bluetooth) when I install blueman? Or, can they both exist at the same time? – BubbaJ Oct 26 '11 at 22:41
  • Tried installing Blueman in live Cd session before attempting to install in the base install. Still having issues with maintaining connection to the bluetooth headset after the first disconnect. Installing Blueman did not resolve the issue for me. – BubbaJ Nov 8 '11 at 14:39

I solved the problem by making the ubuntu 11.10 machine discoverable. So both buttons should by on in the bluetooth screen.

| improve this answer | |
  • I tried making the 11.10 machine visible. I assume that making the machine visible also makes it discoverable. This did not resolve the issue for me. I was still not able to reconnect when the laptop is visible. – BubbaJ Nov 8 '11 at 14:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.