8

I have a new Dell Inspiron 7559 laptop running Windows 10 which requires an external DVD drive. I have tried to install Ubuntu versions 12.02, 14.04, and 15.10 with no luck. When I try to boot from the disk image in UEFI mode the process comes to a halt midway through. If I try to boot using the legacy mode, then the installer does not find the Windows OS. Since I want a dual boot system, I exit from the process here. Also, the installer does not find the Wi-Fi link. Does anyone know the source of this problem? I theorize that It could be that Ubuntu is not Windows 10 savvy, or that the installer cannot use the internal hardware as this is a very new design. Comments?

  • To the poster above: Does linux work if you close your laptop's lid (sleep) and then open it? For me, I get a black screen and then, a line says that Bluetooth driver has failed, or something. Do you get this too? – nirvanaswap Nov 4 '15 at 4:28
4

I am having the same issue with the exact same model. Dell Inspirion 15 7559 with 6th gen intel i7, nvidia geforce gtx 960m.

Will post if successful...

(Be sure to read everything below this line.)

EDIT: Got it working So the problem is with the new processor architecture not being fully supported by this version. (6th gen Intel requores Linux 4.3 .) Here is anew article explaining why and how to fix it in a less concise way: http://www.phoronix.com/scan.php?page=news_item&px=intel-skl-prelim-support

Here's what you do:

  1. when grub shows up, press "e". There should be a line starting with linux, add the word nomodeset to the end of this line. This is a kernel parameter, google it if you want to learn more.

  2. You will have to repeat step 1. when the installation completes and the system reboots.

  3. Choose option 1 or option 2.

    OPTION 1:

    • Do the system updates and activate drivers for the NVIDIA 960.

    OPTION 2.... Make it permanant, use default drivers:

    • modify /etc/defaults/grub so that GRUB_CMDLINE_LINUX_DEFAULT includes nomodeset:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

    • run $ sudo update-grub in the command prompt

EDIT: fix update-grub command

EDIT: Addendum: After installing updates and activating the 3rd party drivers for nvidia, I was able to remove nomodeset from the boot parameters, so making nomodeset permanent is probably unwanted ^_^.

Final Edit: I now have the installation working perfectly. In addition to the steps I listed above, you also need to disable secure boot in the BIOS. If you do not disable secure boot, Windows will override the bootloader and prevent ubuntu from installing.

I ran into an issue where I had installed Ubuntu, could see the partition, but it wouldn't boot after I had started Windows 10 once. After turning off secure boot, I ran boot-repair from a usb running ubuntu, which fixed the boot loader and WIndows hasn't overriden it again. I can also use linux without having it plugged in, which was an issue in the past installation, probably related to secure boot. (NOTE: There is an option at the top level of the UEFI menu to turn secure boot off and revert to legacy bios, do not choose this option. There is another menu where you can configure these independently of each other.)

  • My Dell is an Inspiron 7559. I have tried Ubuntu 12.02, 14.04, and 15.10. If I try booting off the disk in default mode, then the install ultimately stops dead. If I try booting in legacy mode, then it doesn't see the Wi-Fi card, or Windows. I stop here. Recently, I disabled hibernation and fast boot in Windows 10 and then tried using the standard UEFI/Secure Boot. The disk started to be read, but then stopped as before. I believe that the BIOS has an option for "Intel Smart Response". Does anyone know if that could be the problem? – H Freund Oct 31 '15 at 12:51
  • Forget to mention I also have a Dell Inspirion 7559, and have tried those distros as well, as well as Kubuntu and Ubuntu Gnome – Devyn Goetsch Nov 1 '15 at 16:03
  • see solution in edited response^ – Devyn Goetsch Nov 1 '15 at 22:28
  • Does optimus work with this laptop under Ubuntu? If so, what version Nvidia drivers are you using? – James Heald Jan 26 '16 at 22:56
2

If this is the laptop you are talking about, I have the same one. You have to be sure to turn off secure boot. Also, you can install a second hard drive or SSD and simply hit F12 to select which drive to boot from!

Good luck :)

1

I had trouble booting linux (live session). My computer is the following: Dell - Inspiron 15 - 7000 Series - Model: 7559

Display:

  • 15.6" Full HD display with webcam

Performance:

  • Intel Core i5-6300HQ Processor
  • 8GB RAM
  • 256GB Solid State Drive (SSD)
  • NVIDIA GeForce GTX, 960M 4GB Graphics

I used Ubuntu 15.10 with some modified boot parameters and was able to get it to boot a Ubuntu live session. Here are the GRUB boot parameters:

i915.preliminary_hw_support=1
nouveau.modeset=0
  • 2
    If you have another question, please ask it by clicking the Ask Question button. – Karl Richter Jan 30 '16 at 7:28
0

It helps to get the latest bios update. This takes a little skill. I would go into detail but you can research how to do this. There are a couple easier methods, especially if you don't want to dual boot with windows. I installed windows 10 on another partition and updated the bios from windows 10. Get the bios update for your model from dell. This fixed alot of my issues with ubuntu 15.10 running on a dell inspiron 11" 3147.

0

Following these steps fixed my issue:

  1. Boot with live usb.
  2. Spam F12 for boot options, boot with mass storage device
  3. Once at the grub menu, tap 'e' to edit
  4. Go to the end of the line that starts with linux and add acpi=off
  5. Ctrl-X or F10

Making the workaround permanent:

  • sudo nano /etc/default/grub
  • Change line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off"
  • Ctrl-X, press Y and then Enter to save and exit.
  • sudo update-grub
  • Reboot.

protected by Community Feb 17 '16 at 2:06

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.