10

I just installed Ubuntu 15.10 64bit on my Thinkpad and everything works fine, but I installed netbeans 8.0.2 and when I try to launch it, it freezes at startup during the Loading modules phase.

I have openjdk 8 installed. I don't understand this problem since on 15.04 32bit on another computer it works just fine.

When starting netbeans from command line the message is the following:

chrisgaubla@sokioute:~/netbeans-8.0.2/bin$ sh netbeans

OpenJDK 64-Bit Server VM warning: ignoring option PermSize=32m; support was removed in 8.0

5
  • Me too, also on 64bit. The applications "tvbrowser" and "mediathekview" freeze too - a Java Problem with 15.10? – Dino Oct 24 '15 at 10:57
  • Start Netbeans in a terminal and add the messages to your question. – A.B. Oct 24 '15 at 12:24
  • When starting from terminal here's what I get: chrisgaubla@sokioute:~/netbeans-8.0.2/bin$ sh netbeans OpenJDK 64-Bit Server VM warning: ignoring option PermSize=32m; support was removed in 8.0 – Christophe Gaudet-Blavignac Oct 24 '15 at 14:37
  • Have you tried editing /etc/java-8-openjdk/accessibility.properties and commenting out the line assistive_technologies=org.GNOME.Accessibility.AtkWrapper ? – user466465 Oct 29 '15 at 16:38
  • After commenting out the line in accessibility.properties as noted above, Netbeans still freezes since I updated to Ubuntu 15.10. It did eventually get past the "Loading modules" - I left the room and gave it about 20 minutes. When I returned it appeared that Netbeans had loaded fine, but my system was totally locked up. Previously, while trying to load Netbeans I noticed that it was pegging one of my cpu's steadily at 100%. I've lost the entire morning fighting this. I'm going back to Ubuntu 15.04. – CompuSolver Oct 30 '15 at 15:31
4

Same here. The Java 8 build 1.8.0_66-internal-b01 seems to be a little unstable. You could either wait for a newer build to arrive in Ubuntu (https://tracker.debian.org/news/720431) or use OpenJDK 7 for now.

Edit:
This does indeed seem to be a problem with OpenJDK 8, which still seems to exist is build 66-b17. If you need Java 8, you can download Oracle's JDK from http://www.oracle.com/technetwork/java/javase/downloads and set the path to that JDK in the file <netbeans directory>/etc/netbeans.conf (parameter "netbeans_jdkhome"). I couldn't reproduce the problem with the Oracle JDK.

1
  • Hm, unfortunately the problem still seems to occur with build 1.8.0_66-internal-b17. – binary Oct 28 '15 at 17:50
18

To make it work with OpenJDK 8, edit /etc/java-8-openjdk/accessibility.properties and comment out the following line

assistive_technologies=org.GNOME.Accessibility.AtkWrapper

as suggested here: https://bugs.launchpad.net/ubuntu/+source/openjdk-8/+bug/1510009.

3
  • This was also my problem using java-7-openjdk. – Captain Giraffe Dec 17 '15 at 9:44
  • 1
    You just saved me a lot of frustration . Thanks a ton. – Aniruddha Jan 26 '16 at 6:20
  • This worked currently for NetBeans IDE Dev and Java: 1.8.0_91. Thanks @binary . – mixer Jun 24 '16 at 11:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.