0

I'm looking to test (or, with luck, to install) Ubuntu 15.10 from live USB on a MacBook Pro 8,2 with Radeon HD 6770M. Currently, the machine has installed Ubuntu 15.04 with Radeon disabled in grub and works well. I have installed the 15.04 booting the live USB of Ubuntu 15.04 through a 'nomodeset' command in grub options. I'm looking to do the same to testing live the 15.10, but it seems not work.

If I boot the USB normally, the boot stopped at [6.9] with "i8042: No controller found" issue. If I boot removing "quite splash" from grub, the boot stopped at [7.3] with "fb: switching radeonfmfb from EFI VGA" issue. If I boot removing "quite splash" and adding "nomodeset" in grub, the boot stopped after a couple of minutes on "[ OK ] Started WPA supplicant".

Any idea to proceed?

1

Try this, a little tedious but worked for me:

  1. If the system boots without showing you GRUB, when it stalls press "ALT+F1" (or fn-ALT-F1) to enter console mode. Enter your credentials and when the prompt appear enter :

    sudo nano /etc/default/grub

  2. Then find the line "GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash" and enter after "splash":

    i915.lvds_channel_mode=2 i915.modeset=1 i915.lvds_use_ssc=0

so the line should look like this:

`GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash i915.lvds_channel_mode=2 i915.modeset=1 i915.lvds_use_ssc=0"`
  1. Uncomment (remove the "#" before) the line "GRUB_TERMINAL=console"

  2. Exit with CTRL-X and confirm saving the changes without changing the output name.

  3. Then do: sudo nano /etc/grub.d/10_linux

  4. Locate the line

    echo " insmod gzio" | sed "s/^/$submenu_indentation/"

with CTRL-W (you can use the string „gzio“).

  1. Immediately BEFORE this line, enter the following so it looks like this:

    echo " outb 0x728 1" | sed "s/^/$submenu_indentation/"

    echo " outb 0x710 2" | sed "s/^/$submenu_indentation/"

    echo " outb 0x740 2" | sed "s/^/$submenu_indentation/"

    echo " outb 0x750 0" | sed "s/^/$submenu_indentation/"

    echo " insmod gzio" | sed "s/^/$submenu_indentation/"

(one line after the other, don't jump lines. I don't understand why askubuntu website don't let me just press enter once to break a line, anyway...)

Double check your edits carefully.

  1. Save and close this file too with CTRL-X.

  2. Now you can do : sudo update-grub

Update your system, reboot, press ALT and boot into MacOS. Re-Install rEFInd and you can boot back to Ubuntu. First linux option in boot menu is to boot with intel graphic chip, second linux option is to boot with discreet card.

So the key here lies in those lines :

outb 0x728 1
outb 0x710 2
outb 0x740 2
outb 0x750 0

and :

i915.lvds_channel_mode=2 i915.modeset=1 i915.lvds_use_ssc=0

Which deactivate (as I understand) the discreet graphic card so that Ubuntu is not confused at boot (so it finds only one graphic chip).

EDIT: one more thing: if you find yourself stuck at "[ OK ] Any sentence here", you may enter the graphical interface by doing "ALT+F1" and then "ALT+F7" (you may need to hold the -fn key along with the others). It seems to refresh the boot process.

Reference : http://ubuntuforums.org/showthread.php?t=2157775

  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review – David Foerster Feb 7 '16 at 19:09
  • Ok sorry, will modify the answer then – Spike Feb 7 '16 at 22:13
0

I've been able to boot the 15.10 live usb on my MBP 11,3 with the additional grub option "acpi=off" (after "splash"). The graphics are very sluggish though and the installer doesn't actually see my SSD. Maybe you'll have better luck.

In my quest for truth I found this nugget: "If you're using UEFI, do not currently use Unetbootin with Debian iso files due to a bug. " https://help.ubuntu.com/community/Installation/FromUSBStick#Unetbootin-1

did you make your usb from unetbootin?

  • I have tried many different methods, but finally Ubuntu startup disk creator was fine. I did some tries with other distros and I found that Fedora 22 install a complete functionally system on a MacBook Pro 8,2 with nice use of the Radeon graphics. Just need to install manually the Broadcom-43 wifi drivers. So now I have to understand how to port the Fedora graphics driver to Ubuntu. – cialu Nov 9 '15 at 9:55
  • @LucaCiavatta: This is very useful information to debug your issue with Ubuntu. Please add it to your question. It would also help if you ran uname -r, cat /proc/cmdline, lspci -nnk | grep -A2 VGA and modinfo [MODULE_NAME] (with the module name returned from lspci) on your Fedora setup to check the graphics driver configuration in use there. – David Foerster Feb 7 '16 at 19:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.