I am having trouble connecting my Bluetooth speakers with a fresh 15.10 install (EDIT: applies to 16.04 as well). The speakers are connected however they are not listed as an available audio device.

I tried to load the Bluetooth module using:

sudo pactl load-module module-bluetooth-discover
Failure: Module initialization failed

The same speakers have worked perfectly on 14.04. Any ideas how I could properly load the module so I can use my speakers?


3 Answers 3


Solved by using SimFox3 answer in this thread.

Bug and possible solution: actually I found a bug in that make the headset unusable, it seems that the pulse audio module: module-bluetooth-discover works only if started after the X11 session is up. So I have a workaround.

Edit the file:


and comment out (with an # at the beginning of the line) the following line:

#load-module module-bluetooth-discover

now edit the file:


and after the lines:

   if [ x”$SESSION_MANAGER” != x ] ; then
        /usr/bin/pactl load-module module-x11-xsmp “display=$DISPLAY session_manager=$SESSION_MANAGER” > /dev/null

add the following line:

    /usr/bin/pactl load-module module-bluetooth-discover

This way the Pulse audio’s Bluetooth modules will not be downloaded at boot time but after x11 is started.

  • 2
    You are my hero! Did you submit this as a bug report somewhere? This fixed it for me.
    – select
    Nov 25, 2015 at 23:48
  • Worked for me too - this on the cheap & cheerful Lidl bluetooth SBL 4.1 which has previously failed to appear on googling it with Linux. Well done +1! Feb 22, 2016 at 14:33
  • 3
    it works for 16.04 as well, believe or not this bug still exists and seems no one is going to fix this
    – Zippp
    Apr 23, 2016 at 18:54
  • 1
    Great! The same problem in Debian 9 and the same solution...
    – Marlord
    Jun 29, 2017 at 23:35
  • 3
    Is there an upstream or distro bug report for this? I can't seem to find it neither in Ubuntu nor Debian nor upstream...
    – bk138
    Oct 18, 2017 at 14:42

The solution in 16.10 is:

$ sudo apt install bluetooth pulseaudio-module-bluetooth

This answer was originally posted as an edit to the question.

  • Thanks, reinstalling was actually indeed needed.
    – Alex Botev
    Mar 6, 2020 at 10:03

Sometimes, it works after reboot, and such error appears later. In this case you can try the following, which works for me:

pactl unload-module  module-bluetooth-discover
pactl   load-module  module-bluetooth-discover
  • 1
    The unload seems to be the key here. Just loading (as suggested elsewhere) causes an error where it fails to load it. I couldn't get it to run with sudo though - but it worked fine without it Feb 25, 2020 at 11:59
  • 1
    Had to do this in 19.10 also
    – Rqomey
    Mar 2, 2020 at 22:31
  • This worked under 18.04 as well!
    – parsethis
    Mar 31, 2020 at 18:36
  • This totally fixed my problem. Linux Mint 18.3 (Sylvia). Half a connection to bluetooth.
    – brad
    Apr 11, 2020 at 21:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .