With 15.04 (running inside VirtualBox), I used the technique descibed here and it worked fine.

//servername/sharename  /media/windowsshare  cifs  username=msusername,password=mspassword,iocharset=utf8,sec=ntlm  0  0

Now, in 15.10 (still inside the same VirtualBox setup), this does not work anymore. I get an error message at boot and the shares are not mounted. They can however be mounted manually with 'sudo mount -a'.

The error messages :

[   22.497984] CIFS VFS: Error connecting to socket. Aborting operation.
[   22.498336] CIFS VFS: vifs_mount failed w/return code = -101

This suggest a network error but I do not see why, except perhaps because this is running within VirtualBox? But again, the same method worked before.

Then I tried adding the 'x-systemd.automount' flag like I saw in this post:

//servername/sharename  /media/windowsshare  cifs  username=msusername,password=mspassword,iocharset=utf8,sec=ntlm,x-systemd.automount  0  0

I still get the error messages at startup but surprise! ... it sort of works. The share is indeed mounted on the correct mount point and I can acesss it fine. However, on the Gnome desktop, where I have specified that I want to see the mounted volumes using the tweek tool, I see my shares twice but with 2 different types of icons: Click to see screenshot. When I do not use the 'x-systemd.automount' and do 'sudo mount -a' manually, only the lower kinds of icons appear.

I also tried various other combinations of additional flags (like using a credentials file or setting the 'gid=xxxx,uid=xxxx' flags) but it does not change anything.

Does anyone knows a way to fix this ?

  • Hi guys, an answer would be nice ...
    – fi11222
    Nov 2, 2015 at 9:29
  • 1
    I have asked same question, you can look for answer if I got any :-) askubuntu.com/q/696341/294611
    – Alex Jones
    Nov 10, 2015 at 17:20
  • @edward: Thanks. Hope we'll get an answer. This prevents me from migrating to 15.10
    – fi11222
    Nov 11, 2015 at 8:40
  • 1
    you have used right solution noauto,x-systemd.automount,x-systemd.device-timeout=3 thats how it works with systemd and the problem with two icons is just a bug in current desktop environment
    – Alex Jones
    Nov 11, 2015 at 9:12
  • I found the solution and also explained why our old method does not work. askubuntu.com/a/697252/294611
    – Alex Jones
    Nov 12, 2015 at 16:11

1 Answer 1


(answered wrong question)

Don't know if this helps, but I am using 15.10 and I mounted an external drive by editing the /etc/fstab file.

My drive is mounted by placing this at the end, you would have to change it according to whatever is appropriate for your system.

/dev/sde1 /media/external ntfs uid=nobody,gid=users 0 0
  • While this works for actual drives, OP needs a network drive to be mounted. Syntax is different. Not going to downvote this answer, but please do note this is not correct Mar 4, 2016 at 21:28
  • Oh yeah, I misunderstood the question as wanting to mount a drive to be shared by Ubuntu.
    – Tyler Cox
    Mar 6, 2016 at 18:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .