14

I am using Cisco Webex for the online meetings, the problem is that the microphone volume automatically goes to maximum and I just can't decrease it. Is there any way to solve this problem? Any help would be highly appreciated!

24
+50

I had a similar problem. Sometimes it is impossible to prevent applications from trying to adjust the microphone level. With Ubuntu, it is at least possible to prevent ALSA from responding to such requests.

In the configuration file /usr/share/pulseaudio/alsa-mixer/paths/analog-input-internal-mic.conf (you might have to look for the correct file for your microphone, see below), I changed to part

[Element Capture]
switch = mute
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

to

[Element Capture]
switch = mute
volume = 40
override-map.1 = all
override-map.2 = all-left,all-right

and after a sudo alsa force-reload, applications don't magically change the microphone volume anymore.

Above, we use volume = 40, which corresponds to the numeric value shown in alsamixer below the green level control fader as shown here: alsamixer fader with volume level.

If you want to set the volume to the "native" volume of your microphone (0dB of the hardware, without added "mic boost" that can add static noise), adjust this volume number until the top left of alsamixer shows db gain: 0.00, like so:

alsamixer dB gain

How to determine the .conf file for your microphone

  • Run pacmd list-sources.

  • In the output, search for the index: section listing the desired device, e.g.

      * index: 6
        name: <alsa_input.usb-Blue_Microphones_Yeti_Stereo_Microphone_REV8-00.analog-stereo>
        ...
        active port: <analog-input-mic>
    
  • The active port part at the end contains the file name you need to edit in /usr/share/pulseaudio/alsa-mixer/paths/.

    In the above example, it is <analog-input-mic>, so we would edit /usr/share/pulseaudio/alsa-mixer/paths/analog-input-mic.conf for this mic.

5
  • This seems to work for me for Ubuntu 18.04. I came here via the Chromium bug closed as WontFix, in which Chromium refuses to allow users to disable automatic mic adjustment (in my case, the Mic Boost, not the absolute volume); instead they make it each WebRTC app's ability to disable it, but if any app you use there doesn't offer a setting for it, you're screwed. This workaround seems to help. However, even though I specify volume = 40 for my mic boost, the value stays at the value I set in alsamixer, not 40. Suspicious. – nh2 Nov 6 '19 at 0:13
  • I just noticed that I had answered the same question with the same answer here 3 years ago :o – nh2 Nov 6 '19 at 0:25
  • Did work for Linux Mint 19.3 5.4.0-48-generic – Yevgen Nov 19 '20 at 13:29
  • 1
    Doesn't work for me on Ubuntu 20.04 – Suor Feb 6 at 8:21
  • It works, but when i return back to Chrome and Cisco Webex - it says, that i have no mic and auidio at all (it is only webex issue, e.g. in other sites like Youtube sound exist and everything is normal also as in desktop apps like discrod or zoom ). After reset - all configs are back to default. How to prevent such behaviour - i don't know – Dmitriy Litvinov May 26 at 12:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.