1

I am a beginner on Ubuntu and want to install CUDA on Ubuntu 14.04 for running some parallel code for my projects. But I am stuck at this point.

When I run this command on the terminal

lspci | grep VGA

It shows

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)


It does not even shows my graphics card. But when I run

lspci -v

It shows a number of details including

01:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 740M] (rev ff) (prog-if ff)
!!! Unknown header type 7f


Also when I run the 'details' on my operating system, it shows
Processor : Intel® Core™ i5-3337U CPU @ 1.80GHz × 4
Graphics : Intel® Ivybridge Mobile
OS type : 64-bit

But when I run 'Additional Drivers' on my operating system, it shows
NVIDIA Corporation : GK208M [GeForce GT740M]
Using NVIDIA binary driver - version 352.39 from nvidia-352

When I run the command

dpkg -l | grep -i nvidia

It shows the following output

ii  bbswitch-dkms                                         0.7-2ubuntu1                                        amd64        Interface for toggling the power on nVidia Optimus video cards
ii  bumblebee                                             3.2.1-5                                             amd64        NVIDIA Optimus support for Linux
ii  bumblebee-nvidia                                      3.2.1-5                                             amd64        NVIDIA Optimus support using the proprietary NVIDIA driver 
rc  libcuda1-304                                          304.128-0ubuntu0.0.1                                amd64        NVIDIA CUDA runtime library
ii  libcuda1-352                                          352.39-0ubuntu1                                     amd64        NVIDIA CUDA runtime library
rc  nvidia-304                                            304.128-0ubuntu0.0.1                                amd64        NVIDIA legacy binary driver - version 304.128
ii  nvidia-352                                            352.39-0ubuntu1                                     amd64        NVIDIA binary driver - version 352.39
ii  nvidia-352-dev                                        352.39-0ubuntu1                                     amd64        NVIDIA binary Xorg driver development files
ii  nvidia-352-uvm                                        352.39-0ubuntu1                                     amd64        Transitional package for nvidia-352
rc  nvidia-libopencl1-304                                 304.125-0ubuntu0.0.1                                amd64        NVIDIA OpenCL Driver and ICD Loader library
ii  nvidia-modprobe                                       352.39-0ubuntu1                                     amd64        Load the NVIDIA kernel driver and create device files
rc  nvidia-opencl-icd-304                                 304.128-0ubuntu0.0.1                                amd64        NVIDIA OpenCL ICD
ii  nvidia-opencl-icd-352                                 352.39-0ubuntu1                                     amd64        NVIDIA  OpenCL ICD
ii  nvidia-settings                                       352.39-0ubuntu1                                     amd64        Tool for configuring the NVIDIA graphics driver
ii  primus                                                0~20131127-2                                        amd64        client-side GPU offloading for NVIDIA Optimus

I think this means that I have the drivers installed but my GPU is not being detected.

Some things that I have already done are installing cuda on this system I have already installed the deb package using the following commands

sudo dpkg -i cuda-repo-ubuntu1404_7.5-18_amd64.deb 
sudo apt-get update 
sudo apt-get install cuda

But now when I run any of the samples, like devicequery, it shows

cudaGetDeviceCount returned 38
-> no CUDA-capable device is detected

I have been through a number of other discussions but they are beyond my level of understanding. Can anybody please suggest what I should do next because I really need to install CUDA on this system. Thanks in advance

1

you have both libcuda1-304 and libcuda1-352 together with the nvidia-304 driver!!!!!

firstly uninstall everything having "304" in it.

The following applies if you installed bumblebee and the nvidia driver and not if you have installed nvidia-prime:

edit /etc/bumblebee/bumblebee.conf and change the lines:

line 22: >Driver=nvidia

line 55: >KernelDriver=nvidia-352

line 58: >LibraryPath=/usr/lib/nvidia-352:/usr/lib32/nvidia-352

line 61: >XorgModulePath=/usr/lib/nvidia-352/xorg,/usr/lib/xorg/modules

lastly you may have to

sudo "a-cuda-application"

at first in order to get cuda working for the first time and then you can use it without "sudo" for the rest of the session.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.