19

I upgraded to Ubuntu 15.10 and now if I want to open VMware Player it doesn't do anything. I also uninstalled and installed it again, still nothing.

What can I do?

35

The solution below applies to versions of VMWare prior to 12.1.0. The 12.1.0 version of VMWare does not require this fix.


VMWare and VMPlayer are in fact looking for a specific library string. You can execute VMWare/VMPlayer from the terminal by executing

export LD_LIBRARY_PATH=/usr/lib/vmware/lib/libglibmm-2.4.so.1/:$LD_LIBRARY_PATH

then vmware or vmplayer

I made this a permanent change on my system by executing instead

executing sudo nano /usr/bin/vmware and adding the line

export LD_LIBRARY_PATH=/usr/lib/vmware/lib/libglibmm-2.4.so.1

after the line export PRODUCT_NAME...

Press ctrl+o to save and ctrl+x to exit: VMWare will now work.

To perform the same function for VMPlayer, execute the same changes to /usr/bin/vmplayer

| improve this answer | |
  • This is just a third party indicating that the above works. Be cautious of line breaks in the quoted commands. Also, have your key ready. It needed me to reenter my key. Fortunately, I still had that saved. Don't forget - if Charles helped you out, make sure you mark their answer as solving the problem. – KGIII Oct 23 '15 at 23:07
  • @KGIII I didn't need to re-enter my key, although I do have it handy for those times I reinstall! – Charles Green Oct 24 '15 at 1:14
  • 1
    @Lurrdock This is actually a separate problem, but VMWare requires several items to be present - this is its nice way of asking. You will need to execute sudo apt-get install build-essential linux-headers-generic at a minimum. I would suggest starting a new question about this. – Charles Green Oct 24 '15 at 13:53
  • 1
    I have the same problem, but this solution doesn't seem to be enough. I am able to launch wmplayer, then it asks me to compile and install several modules. When I authorize it, it gives me a lot of errors like (vmware-gksu:7071): GLib-GObject-WARNING **: Two different plugins tried to register 'BasicEngineFc'. (vmware-gksu:7071): GLib-GObject-CRITICAL **: g_object_new: assertion 'G_TYPE_IS_OBJECT (object_type)' failed – marcosh Oct 29 '15 at 22:48
  • 1
    this worked for me askubuntu.com/questions/691715/vmware-player-on-ubuntu-15-10 – mango Dec 2 '15 at 12:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.