11

In the newest Nautilus 3.18 the smallest folder/icon size is really too big. Is there some way to hack (or something) this program and set a smaller one? enter image description here

  • Have you installed the gnome tweak tool? That is if you are using gnome. Otherwise if you use unity install the unity tweak tool that should give you everything you need. – RiaanV Oct 23 '15 at 21:30
  • I tried searching an appropriate setting in GNOME Tweak Tool, but the only thing I see is characters dimension, nothing more... – nplezka Oct 24 '15 at 12:53
  • have you looked under the zoom settings? – RiaanV Oct 24 '15 at 15:37
  • Sure! It's already too big. I was on Nautilus 3.14 before 3.18 and the icons were way small... – nplezka Oct 28 '15 at 18:19
21

This setting is now a little hard to find in the GUI since it is not explicitly labeled.

Click on the icon view button to bring up settings dialog; then move the slider to the left to change the icon size to small.

enter image description here

You can find the same setting in dconf-editor through:

org >> gnome >> >> nautilus >> icon-view >> default-zoom-level: [small, standard, large]

There is also a thumbnail-size setting that is supposed to work along with the small setting; but nautilus does not seem to follow this setting and it did not have an effect. You may want to file a bug report.

  • Well, I already did it, but it's way too big compared to the old Nautilus 3.14... :/ – nplezka Oct 28 '15 at 18:17
  • I believe that's as small as it gets by default. There's a thumbnail-size setting that's supposed to work when the view is set to small, but it doesn't seem to actually have an effect. You may want to file a bug report. – chaskes Oct 28 '15 at 19:32
  • 1
    Shortcut: Ctrl + mouse-scroll – UniversallyUniqueID May 25 '16 at 11:47
  • Depending on the Linux distribution, in which you are using nautilus, you might have to install dconf-editor, i.e., sudo apt-get install dconf-editor on terminal. – loved.by.Jesus Jun 7 '17 at 14:45
3

Use:-
Ctrl+ To increase the font size
Ctrl- To decrease the font size

(Press and hold the Ctrl key, then lightly tap the + key, then release both)

  • Please have a look at my edits and read the Editing help as well for your education... – Fabby Mar 18 '18 at 12:19
1

Going below 48px requires changing the Nautilus source code and recompiling. (Yes, they hard-coded icons sizes.)

INSTRUCTIONS FOR NAUTILUS 3.20.4 ON UBUNTU GNOME 17.04

  1. Install the following dependencies:

    libgd-dev
    autotools-dev
    libexif-dev
    libexempi-dev
    libselinux1-dev
    libtracker-sparql-1.0-dev
    libext-dev
    libxml2-dev
    libgnome-desktop-3-dev
    

    Each one installs a bunch of other stuff, so hopefully I've given you the correct parent package name. I apologize for not recalling with 100% accuracy exactly what I installed, but this looks fairly correct to me immediately after my install. (Notify me if I'm inaccurate anywhere.)

  2. Download from the Nautilus snapshots website the version of Nautilus that you are currently using. To find that out, run nautilus --version from the terminal. After downloading the archive, unzip it to whatever directory you want to work from.

  3. From within the unzipped package, open the file nautilus-icon-info.h. Within the first several lines you will see various sizes designated for the particular scroll-setting options. For instance, within the file for version 3.20.4 the icon sizes start on line 36. Change each of those levels to whatever you want to use so that you can make the icons much smaller (or larger).

  4. After editing and saving the file, it's time to configure, compile, and install. Run the following commands from the terminal from within the base directory of the version of nautilus that you have downloaded and unzipped. Make sure that you are within the base of the folder structure of the nautilus directories!

    ./configure
    make
    sudo make install
    

    These can be run altogether with the command

    ./configure && make && make install
    

If the ./configure command fails it's because you are missing some other dependencies. I apologize if my list of dependencies above was incomplete. Google (or whatever search engine you want) to find what package it is that you need. You can use Synaptic to search for what you need if you're unsure even after Googling.

Once installed, I suggest a reboot just to make sure that every single thing is reloaded properly. You can now tweak with your icon sizes as you wish.

Have fun!

0

According to this Google+ post, starting from Nautilus 3.15, it seem that the "small" icon size 64, is the smallest option available (so the new "zoom" slider will not work as intended).

More details in this GNOME Git commit.

There are more informations and some are misleading. Also, I found somewhere on GNOME bugs a mention that it will not be fixed as the decision was taken as temporary solution for a bug elsewhere.

At this moment the only solution (not tested) seem to be rebuild of nautilus using different icon size for "small". Or "downgrade" if possible.

0

Nautilus 3.22 .Open Nautilus (not maximized) on Desktop with all the rest windows minimized and then press CTRL+Scroll mouse wheel. That does the trick.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.