2

Just installed Ubuntu 15.10, and my second monitor does not use the correct resolution. It defaults to 1024x768, even though it should support 1920x1080. Previously, on Windows this was not a problem. I had this same problem with this monitor on Arch Linux, and was able to correct it like this:

  • The EDID had a bad checksum
  • Set the IgnoreEDIDChecksum option on the Xorg configuration file
  • In /etc/X11/xorg.conf, under the Device section:

    Option "IgnoreEDIDChecksum" "DFP-4"
    

I'm not able to find that config option in Ubuntu (and I'm not sure if there is a better way to do it). I've also tried adding a new mode through xrandr, but would get the following error:

xrandr --addmode DVI-D-0 1920x1080_60.00
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  41
  Current serial number in output stream:  42

Does anybody know how I can correct the problem, or how I can provide more information? I'm using the proprietary NVIDIA driver (the open source driver would just display a black screen on that monitor).

3

I was able to fix the issue by generating an xorg.conf file through the NVIDIA settings application, then making the following entry in the Device section:

Option "IgnoreEDIDChecksum" "DFP-4"

Where DFP-4 is the name of the monitor.

| improve this answer | |
  • I'm having the same issue, but my xorg.conf file has three different DEVICE sections. Which one did you add that line to? – neuronet Sep 11 '17 at 13:45
  • @neuronet sorry for the delayed response. I'm not using the same setup anymore, so don't know for sure what the config looks like. If I remember correctly, I only had one DEVICE section. Either that, or I just put this in the first one that I found. – nicksmaddog Sep 15 '17 at 18:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.