Upgrade my laptop to Ubuntu 15.10. After I restart it freeze in Ubuntu logo.

I found out that I'm having problem with the new kernel (Linux 4.2.0-16-generic). If I use the 2nd version (Linux 3.19-generic) it boots properly.

When I tried removing Linux 4.2.0-16-generic and run sudo update-grub it always detects Linux 4.2.0-16-generic.

How would I make Linux 3.19-generic the default upon boot up? And/Or permanently remove Linux 4.2.0-16-generic?

  • I have a similar problem with 4.2.0 and later kernels, so I have been using 3.19. However, I recently tried 4.1.12 and all is well thus far. You might try it if you want a more current kernel. – Dunham Jan 19 '16 at 21:16

Install Synaptic and remove 4.2 kernel image and headers.

You removed only meta-packages.

  • I already did this. I search and remove every 4.2 Kernel in Synaptic. When I restart, 4.2 still shows in grub. What did I missed? – Max Oct 23 '15 at 18:21
  • You did not search well ;-) Please add output of dpkg -l | grep linux-image to your question. – Pilot6 Oct 23 '15 at 18:24
  • If you like, you can vote to delete this correct answer.))) – Pilot6 Oct 24 '15 at 12:23
  • @Max: Answer is correct: please edit your answer and provide the output of dpkg -l | grep linux-image... – Fabby Oct 25 '15 at 14:05
  • @Fabby update-grub is run automatically when you remove kernels. – Pilot6 Oct 25 '15 at 14:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.