2

Last night I attempted to upgrade from 15.04 to 15.10. Everything went fine until the installer got to the Installing the upgrades step, where it hangs (stops progress) at Installed libxfce4ui-1-0 (i386). The terminal pops up, the last line of which is Found memtest86+ image: /boot/memtest86+.bin. I also have ~50% iowait on my processor, so I let it sit overnight to see if it could figure out what it needs to do. No change. I also don't see anything obvious going on background-wise.

Here's something from /var/log/dist-upgrade/main.log: 2015-10-23 08:23:50,551 WARNING no activity on terminal for 300 seconds (Installed libxfce4ui-1-0 (i386))

Here's everything from /var/log/dist-upgrade/apt-term.log:

Found initrd image: /boot/initrd.img-3.19.0-26-generic
Found linux image: /boot/vmlinuz-3.19.0-25-generic
Found initrd image: /boot/initrd.img-3.19.0-25-generic
Found linux image: /boot/vmlinuz-3.19.0-15-generic
Found initrd image: /boot/initrd.img-3.19.0-15-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin

Those are all the clues I know how to gather at this point. Any help will be appreciated.

The strange thing is that I didn't even know I had XFCE installed since I always use Unity. Is there a way to tell the installer to skip this step without aborting the installation and as a consequence completely breaking my installation? Thank you in advance.

Update

According to Upgrade hangs on ttf-mscorefonts-installer, the command ps -ejHf can be used to gather some more clues as to what might be wrong. For instance, ps -ejHf | grep wily returns:

root      5417  4359  2602  2602  0 Oct22 ?        00:04:22           /usr/bin/python3 /tmp/ubuntu-release-upgrader-e76uh732/wily --mode=server --frontend=DistUpgradeViewGtk3
root     26681  5417 26681 26681  1 Oct22 pts/1    00:11:28             /usr/bin/python3 /tmp/ubuntu-release-upgrader-e76uh732/wily --mode=server --frontend=DistUpgradeViewGtk3

That's not terribly useful, but at least it's something.

  • Remove the package sudo apt-get purge libxfce4ui-1-0 and try to start the upgrade again sudo do-release-upgrade – A.B. Oct 23 '15 at 12:42
  • @A.B., I wasn't able to finish the upgrade, but I have a functioning system without XFCE installed in case that ever becomes a problem again. I had to do sudo dpkg --configure -a in a terminal before sudo apt-get purge libxfce4ui-1-0, just so you know. Ubuntu says it's 15.10 even though I didn't finish all the steps for upgrading. Could you please post your suggestions as an answer to this question so that I can give you some street cred? – Joel DeWitt Oct 24 '15 at 23:21
  • Ok, done. And please, check the last step in my answer. – A.B. Oct 25 '15 at 15:01
2

As you said in your comments, this was the solution for you:

sudo dpkg --configure -a
sudo apt-get purge libxfce4ui-1-0
sudo do-release-upgrade

If your system says, it's 15.10, everything is ok.
But you should check /etc/apt/sources.list for vivid entries and replace them with wily. After that execute:

sudo apt-get update
sudo apt-get dist-upgrade

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.