2

I have an ultrabook from a computer-building factory (it's not name brand),
and I run Ubuntu 14.04.

I lack options for deactivating touchpad while typing and activate two-finger-scroll and I am also unable to use synclient to edit the touchpad features.

Here's the output from xinput:

ina@laptop:~$ xinput
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer            id=4    [slave  pointer  (2)]
⎜   ↳ ImPS/2 Generic Wheel Mouse            id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard           id=5    [slave  keyboard (3)]
    ↳ Power Button                          id=6    [slave  keyboard (3)]
    ↳ Video Bus                             id=7    [slave  keyboard (3)]
    ↳ Power Button                          id=8    [slave  keyboard (3)]
    ↳ Sleep Button                          id=9    [slave  keyboard (3)]
    ↳ USB 2.0 Camera                        id=10   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard          id=11   [slave  keyboard (3)]

This is what happens when I try to run synclient:

ina@laptop:~$ synclient
Couldn't find synaptics properties. No synaptics driver loaded?

When i check the software center I can see that i have this package installed:
xserver-xorg-input-synaptics-lts-vivid

List of things I've tried:
- Reinstalled xserver-xorg-input-synaptic-lts-vivid
- Installed both tpconfig, kde-touchpad and gpointing-device-settings
- Copied 50-synaptics.conf from /usr/share/X11/xorg.conf.d to /etc/X11/xorg.conf.d (but I had to create this folder).

Touchpad
Partnr: 640901100105
Name: TS - U731 - Touchpad BYD BTP10463-212 A2 Mutual Capacitance Multi-Finger CX11 NPB

0

Linux 4.6 now treats BYD touchpads as touchpads, see patch.

However it's not supported by synaptics yet as of xserver-xorg-input-synaptics-1.8.2 (current version in xenial), so synclient and other GUI tools (e.g. the KDE kcm_touchpad system settings module) cannot configure the touchpad behavior yet.

The issue is tracked as launchpad #1424293.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.