2

Yesterday i tried to do a dist-upgrade to 15.10, and it got broken.

The fact is that the hard disk had no much free disk space (around 650mb), and the upgrades are over 1500mb.

Upgrade manager didn't work, so I entered,

sudo apt-get update
sudo apt-get dist-upgrade
sed -i 's/vivid/wily/g' /etc/apt/sources.list
sudo apt-get update
sudo apt-get upgrade

and seeing that it was accessing Wily, I upgraded packages by hand (first dependencies and libraries), and all remaining packages later.

The upgrade worked almost fine, except one thing: previously I had to uninstall some larger packages I had installed (like Gimp, Inkscape, Scribus, Blender, Krita, Openshot, etc.) and I can’t install them back:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 libgtk-3-0 : Depends: libmirclient9 (>= 0.17.0+15.10.20151008.2) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Is there any way to fix this? Or the only way is to do a fresh install over it?

  • Please edit your question and add the output of apt-mark showhold. After that, notify me with a comment containing "@ByteCommander". Thanks. – Byte Commander Oct 23 '15 at 8:33
  • Edit your question and add the output of apt-cache policy libgtk-3-0 libmirclient9 and the output of sudo apt-get install -y libmirclient9 – A.B. Oct 23 '15 at 8:37
  • thanks! in the meanwhile i actually fixed by trying "sudo apt-get install libmirclient9" (that shown "Depends: libmirprotobuf3" ), then "sudo apt-get install libmirprotobuf3" (that shown "Depends: libprotobuf-lite9v5"), and then "sudo apt-get install libprotobuf-lite9v5" - it removed all packages that were conflicting, and i finally could install inkscape and gimp - but anyway, thanks a lot @ByteCommander and A.B. , your feedback is really useful for when i got into similar issues eventually!! :) – Paulo Silva Oct 23 '15 at 11:12
  • anyway, what i have now is (i guess it shows it’s perfect now): pastebin.com/raw.php?i=qfmN4HHB – Paulo Silva Oct 23 '15 at 11:37
1
  • Force the installation of libprotobuf-lite9v5

    sudo apt-get install libprotobuf-lite9v5
    
  • Repair the system with

    sudo apt-get install -f
    
  • Mark the package as being installed automatically

    sudo apt-mark auto libprotobuf-lite9v5
    
  • Install the needed packages

    sudo apt-get install gimp
    sudo apt-get install inkscape
    

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.