79

Since the Ubuntu 15.10 upgrade, google-chrome-stable keeps asking if it should be set as default browser, even though it already is. I tried to reinstall it, but that didn't help. Any ideas?

  • iirc , go to general settings --> uncheck Always check if chrome is your default browser – Ravan Oct 23 '15 at 8:44
  • But it shouldn't report that it is not the default browser while it already is. I suspect a bug here. (I noticed it too. Upgraded just this morning so can't investigate just now.) – Jos Oct 23 '15 at 8:47
  • 1
    Yeah, that's the point. It says it is not the default browser in the settings, and if I click on "Set to default browser" nothing changes. – Yanick Nedderhoff Oct 23 '15 at 11:48
  • 1
    First of all, this forum is not for bug reports, as stated in FAQ. Here is information how to report bugs. And here is a workaround for your problem: – Yurii Kolesnykov Oct 24 '15 at 2:16
  • 1
    @YanickNedderhoff I have proposed edit for the mentioned anwser. But before they reviewed, replace "Profile 1" with "Default" in path. – Yurii Kolesnykov Oct 25 '15 at 20:32
54

For the working fix, see the end of this answer.

INITIAL ANSWER Oct 28th 2015 (outdated fix)

To avoid being asked if you want to use Chrome as the default browser, use the following workaround (proposed here and suggested in the comment section of this question by Yurii Kolesnykov):

Open the file ~/.config/google-chrome/Default/Preferences with a text editor.

Find the line

"check_default_browser": true,

and replace it with

"check_default_browser": false,

In my case, the file was >200k characters, for which reason gedit crashed a few times. If it is the same in your case, you probably want to use a terminal-based editor like vi.

Please note that this is a workaround, the problem itself has to be fixed by the Chrome developers.

UPDATE Nov 24th 2015

As Danilo Piazzalunga mentioned, the bug is confirmed. As NicDumZ suggested, please vote up this bug by clicking on

Does this Bug affect you?

to raise attention. Thanks!

UPDATE Feb 20th 2016

As reported first by Ron Thompson and 3vi1 in the comment section; and finally confirmed by myself (using Ubuntu 15.10), this workaround doesn't seem to work anymore, at least not for everyone, after reinstalling google-chrome. Everybody who used this workaround should try to avoid reinstalling chrome.

I again encourage you to say that you are affected by the bug on launchpad (currently 302 people).

UPDATE April 5th 2016 (Working fix!)

A fix has been proposed on launchpad that apparently did the job for a couple of people:

To apply the fix, change line #198 in the file /usr/bin/xdg-settings from

command="`grep -E "^Exec(\[[^]=]*])?=" "$file" | cut -d= -f 2- | sed -e 's/ .*$//'`"

to

command="`grep -E "^Exec(\[[^]=]*])?=" "$file" | cut -d= -f 2- | sed -e 's/ .*$//' | head -n 1`"

UPDATE July 25th 2016 (Working fix!)

Update to the proposed fix for (K)Ubuntu 16.04:

To apply the fix, change lines #177 and #202 in the file /usr/bin/xdg-settings from

command="`grep -E "^Exec(\[[^]=]*])?=" "$file" | cut -d= -f 2- | first_word"

to

command="`grep -E "^Exec(\[[^]=]*])?=" "$file" | cut -d= -f 2- | first_word | head -n 1`"

Then go to Google Chrome settings and set Chrome as default browser.

UPDATE Jun 1st 2017

The Bug has been closed and marked as "Fix Released" as of today. Quoting the user Olivier Tilloy (osomon):

If I read the report correctly, the issue was fixed in xdg-utils in xenial. Wily has been EOL for almost a year, so I am closing the bug.

no longer affects: chromium-browser no longer affects: google-chrome-beta (Ubuntu) no longer affects: google-chrome (Ubuntu) Changed in chromium-browser (Ubuntu): assignee: Chad Miller (cmiller) → nobody status: In Progress → Invalid Changed in xdg-utils (Ubuntu): assignee: Chad Miller (cmiller) → nobody status: Confirmed → Fix Released

  • 1
    Could you suggest following the bug, and voting it up by clicking "Does this bug affect you?" ? Thanks! – Nicolas Dumazet Nov 24 '15 at 7:44
  • It appears that bug report is for Chromium, yet this error also applies on Google Chrome. Does that matter? Also, the line "check_default_browser" does not appear in that config file for me. – Nicomachus Dec 8 '15 at 0:55
  • Yeah, it affects both Chromium and Chrome. But Chrome is based on Chromium, so if it's fixed, it should be fixed for both. About that missing line: I don't know. May just add the line and see if it works? – Yanick Nedderhoff Dec 11 '15 at 14:03
  • 3
    Just to confirm... the new solution offered (replacing the command regex) works for me on 15.10 :) Thanks. – TacB0sS Apr 16 '16 at 13:06
  • 2
    UPDATE April 5th 2016 (Working fix!) fixed this problem for me, on Ubuntu 15.10 with Chrome Version 50.0.2661.102 (64-bit) – CharlyDelta May 13 '16 at 12:24
3

This has been tracked down as a bug in XDG utilities, and it affects Chromium Browser, too.

See LP Bug #1509139.

-1

I was having the same problem with 15.10. Each time I rebooted and started chrome it complained it was not the default browser even though settings details Default Applications shows it default for web. I noticed that firefox was default for photos, so set that to image viewer. After a total of one reboots chrome is no longer complaining. I should try a few more times before I claim this solved my problem but wanted to share the initial result if anyone is in the mode of trying things themselves.

  • Update: Might be a red-herring. chrome://settings is still showing that chrome is not my default browser. I must have hit the "Don't Ask Again" button by accident during the testing. I can't find the preferences file in order to reverse that decision – mrh53 Dec 31 '15 at 17:36

protected by Community Oct 24 '15 at 3:11

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.