What has happened: I had installed Windows on my hdd abdicate Ubuntu 14 on the ssd. Home and swap were also on the hdd.

Then I decided to remove Windows and deleted all (exceptthe home and swap) Partitions on the hdd.

Then I tried to reboot but it was not possible to boot from ssd.

Further information: BIOS settings are ttached as screenshots. GParted screenshots I took with a live CD are also attached.

Question: Can anybody tell me what to do now? I would really like to boot into my Ubuntu.

Boot menue SSD in GParted

  • The GParted screenshot shows the partition of your USB drive and not of your HDD or SDD, isn't it?
    – Alberto
    Oct 23, 2015 at 8:28
  • No it is really a 16GB SSD. Ubuntu needs (without swap and home)only about 6GB)
    – eDeviser
    Oct 23, 2015 at 8:34

4 Answers 4


whats the error? what does your grub look like you could reinstall grub. Boot to live cd and do fdisk -l find your hardrive "/dev/something" and do grub-install /dev/whatever.

  • I get no error, it is simply not possible to boot into any device. If I chose the SSD for booting, the Boot Menu jugs appears again. May be the Grub bootloader had been on the HDD.
    – eDeviser
    Oct 23, 2015 at 9:52
  • "The boot menu just appears again" you make it sounds like a bios (or uefi from what it looks like) or a failing drive issue trying to boot it should at least show something. it really shows nothing and goes straight to the boot screen again? what kind of laptop do you have? what info does
    – Seth_fox
    Oct 23, 2015 at 10:07
  • I tried installing grub, but I get these errors: On running with sudo it says: grub-install: error: cannot open directory /boot/grub/i386-pc: No such file or directory. On running without sudo it says: grub-install: error: failed to get canonical path of /cow.
    – eDeviser
    Oct 23, 2015 at 10:16
  • whats the errors "The boot menu just appears again" could be a bad drive. Unlikely but still a possibility considering your ssd does not look newer based on its size trying to boot it should at least show something. what kind of laptop do you have? check the health of the ssd by using what your manufacturer recommends
    – Seth_fox
    Oct 23, 2015 at 10:20
  • askubuntu.com/questions/254491/… heres a workaround get grub-install to work and report back im sure its grub get grub working first before you spend a lot of time testing the drive
    – Seth_fox
    Oct 23, 2015 at 10:25

May I should try to run the Boot-Repair Tool. Link for Boot-Repair


I'm not shure at all, cause I`m just an SoftwareDEveloper for Microcomputer, but here are some suggestions and further information.

I'm running a ThinkPad E540. In Bios UEFI is Enabled. After selecting one device in Boot Menu the screen becomes black for about one second, and then the Boot Menu is shown again. Maybe the MBR and GRUB was located on the HDD and I deleted them, because the HDD is now empty, except the home partition and the swap partition.


I figured out a first solution:

First I created a small partition on the HDD (/dev/sda1) and marked it with the boot-flag. Then I was able run grub-install /dev/sda. Then I rebooted and disabled Secure Boot and disabled UEFI in Bios. After that I was able boot. I saw the GRUB Bootloader and selected my Ubuntu and it booted up. :-)

But while loading Ubuntu it says on the Screen that it was not possible to mount /boot/efi.

Well I can go on now working with my system, but if someone has further Ideas, please let me know.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .