Just upgraded from 15.04 to 15.10 via apt-get dist-upgrade. Nothing was customized, everything running from official repos.

Before upgrade I already purged all fglrx proprietary driver from the system and running on standard radeon driver.

The upgrade went successful and after booting into new 15.10 im installing fglrx again via Software & Updates for proprietary driver, no errors installation was success.

However during booting up to make the driver kicks in, the booting stucked at below error:

fb: switching to fglrxdrmfb from EFI VGA

My display:

root@mylenovo:/etc/apt/sources.list.d# lshw -c display
       description: VGA compatible controller
       product: Mullins [Radeon R4/R5 Graphics]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 1
       bus info: pci@0000:00:01.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=0
       resources: irq:37 memory:e0000000-efffffff memory:f0000000-f07fffff ioport:3000(size=256) memory:f0c00000-f0c3ffff memory:f0800000-f081ffff

Any thing that I missed causing fglrx not to work?


2 Answers 2


I guess you have read the Wily release notes saying

AMD's fglrx driver does not work with the current kernel (1493888).
It is warmly recommended to uninstall the fglrx driver before upgrading to
Ubuntu 15.10.
The open source "radeon" driver can be used as a temporary replacement
until a fix is available. 

Why else would you have removed fglrx before upgrade in the first place?

Either downgrade to Kernel 4.1 or use radeon until a fix of fglrx becomes available.

Bug report: https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/1493888

  • Ahh i forget the very important thing with new release which is to read the release note first!! Thanks! Oct 23, 2015 at 7:11
  • That explains everything… They should pop up a big fat messagebox when core stuff like that is broken. (Currently, I’m almost sorry for having updated things.) Fact is the fglrx and fglrx causes segfaults within lightdm. I wonder how that boils down to the kernel. Anyway +1
    – e-sushi
    Oct 26, 2015 at 16:45

The fglrx bug is now solved.

Before, I had to boot on my backup install to disable fglrx and use the open driver instead, which is slow. Maybe Grub advanced booting on the same install but using the previous kernel works for those who are stuck.

Since, I updated Ubuntu through Update Manager, and also updated fglrx-core package through Synaptics Packager Manager (not sure this is needed). Then, I switched the graphic driver back to fglrx-update and rebooted.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .