1

Today I attempted to upgrade from Kubuntu 14.10 to Kubuntu 15.04 on a ThinkPad X250 notebook following this guide: https://help.ubuntu.com/community/VividUpgrades/Kubuntu

I came to the dialog box asking to confirm "Package Changes". I selected "Start Upgrade". The upgraded started but now it is stuck. I can see the window "Distribution Upgrade" but it is greyed out. It's like that for at least 6 hours now. I think the last thing I saw before the window was greyed out was something like "configuring... systemd"

Kubuntu is still responding. I have a notification that uppdates are available for my system. lsb_release -a shows:

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 15.04
Release:        15.04
Codename:       vivid

In /etc/apt/sources.list all repositories point to vivid universe.

Something similar seems to have happened here. But this guy restarted his system and had to perform a fresh install. This could be a similar issue, but there the distribution upgrade window was not grayed out. Here the upgrade was stuck but opposed to there I cannot see the terminal. This is also different as it hangs somewhere else. However, following but I followed the idea to check with ps which processes might be running:

$ ps -ef | grep upgrade
root      2877  1659  3 14:23 ?        00:12:27 /usr/bin/python3 /tmp/ubuntu-release-upgrader-uirakud8/vivid --mode=desktop --frontend=DistUpgradeViewKDE

If I try to close the Distribution Upgrade window a Warning appears:

Application "ubuntu-release-upgrader" is not responding
You tried to close window "Distribution Upgrade" from application "ubuntu-release-upgrader" (Process ID: 2586) but the application is not responding.
Do you want to terminate this application? 
Warning: Terminating the application will close all of its child windows. Any unsaved data will be lost.

What should I do to finish the upgrade? Is it safe to restart my computer and try again?

7
  • Have you also Unity installed? Compiz isn't necessary for KDE. Try to remove the compiz packages in tty1 (Ctrl-Alt-F1). – A.B. Oct 23 '15 at 8:44
  • No I do not have unity. In fact, compiz-core is not even installed. I should check for the other packages. Ctrl-Alt-F1 works when the boot hangs at starting version 219. Thanks! – Fabian Rost Oct 23 '15 at 8:47
  • Start the Recovery Mode in Grub. You can find this menu entry behind Advanced. – A.B. Oct 23 '15 at 8:47
  • I do not have compiz-core or compiz-gnome installed. – Fabian Rost Oct 23 '15 at 8:51
  • Other compiz packages? dpkg -l | grep compiz – A.B. Oct 23 '15 at 8:52
2

Here is what I did to fix it. In the end I basically upgraded to 15.10 without getting 15.04 to run properly. First I killed the upgrade process:

$sudo kill 2877
$sudo dpkg --configure -a

Configuration file '/etc/systemd/logind.conf'
 ==> Modified (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      Z     : start a shell to examine the situation
 The default action is to keep your current version.
*** logind.conf (Y/I/N/O/D/Z) [default=N] ?

I had manually edited logind.conf before, so this question makes sense. Maybe, this was the point where the upgrade was stuck. I answered Y.

$ sudo apt-get update

gave the following message:

W: Unknown Multi-Arch type 'no' for package 'compiz-core'
W: Unknown Multi-Arch type 'no' for package 'compiz-gnome'
W: Unknown Multi-Arch type 'no' for package 'compiz-core'
W: Unknown Multi-Arch type 'no' for package 'compiz-gnome'
W: You may want to run apt-get update to correct these problems

then I performed an upgrade of my packages using aptitude. Which gave me the following errors:

Errors were encountered while processing:
 libqgpgme1
 kde-telepathy-auth-handler
 kdepim-kresources
 cups-browsed
 cups-daemon
 cups-core-drivers
 cups
 hplip
 printer-driver-hpcups
 printer-driver-postscript-hp

I removed exactly those packages using aptitude and performed another upgrade. This one did not show errors. The I performed another upgrade. Then I rebooted my machine but it hangs while booting. It says starting version 219 on the screen.

I installed the package xinit. I ran sudo dpkg-reconfigure lightdm to select lightdm as the default window manager. Now I'm able to see the login screen for a second until the screen turns black. I switched back to sddm: I ran sudo dpkg-reconfigure sddm and selected sddm.

Then I booted into root console and performed do-release-upgrade. This did hang after a while. Then, I upgraded all packages with aptitude. After 2 or 3 reboots I can now login to KDE again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.